Cisco 7941G - Unprovisioned

Hello All,

I admit I am a newbie with Linux, Asterisk, FreePBX and the Cisco 7941G. I am not a newbie with computers as I have a user/programmer/builder since 1979.

I have search the net and this site and found lots of info that got me several steps closer but after 4 days I am still stumped!

I have volunteered to assist a non-profit group to setup a VOIP system using Asterisk and have run into a problem. I used the AsteriskNOW distro to install the system on a server. I have several Cisco 7941G phones and I have updated them to run SIP specifically SIP41.8-3-1S. I have the Mikrotik router setup to handle DHCP and the Option 150/66 for tftp. The phones are requesting the files from the tftp server as I am getting the following messages when I do a tcpdump on port 69

17:56:42.035714 IP > 31 RRQ “CTLSEP0022555xxxxx.tlv” octet
17:56:42.188137 IP > 32 RRQ “SEP0022555xxxxx.cnf.xml” octet
17:56:42.300262 IP > 27 RRQ “XMLDefault.cnf.xml” octet

I tested the tftp server by using a tftp client on a windows computer to download the files and that works.

The phones are getting their IP and DHCP server info.

Thanks in advance for any assistance!


I found the log files in the 7941G and this is what it is logging over and over.

NOT 17:10:40.613415 tftpClient: auth server - tftpList[0] =
NOT 17:10:40.614219 tftpClient: look up server - 0
WRN 17:10:40.616993 SECD: WARN:lookupCTL: CTL update in progress, no old CTL, assume TFTP NONSECURE
NOT 17:10:40.625173 tftpClient: secVal = 0xa
NOT 17:10:40.626016 tftpClient: is a NONsecure server
NOT 17:10:40.626791 tftpClient: temp retval = SRVR_NONSECURE, keep looking
NOT 17:10:40.627526 tftpClient: retval = 10
NOT 17:10:40.628342 tftpClient: Non secure file requested
NOT 17:10:40.641979 TFTP: [31]:Requesting CTLSEP0022555CFA78.tlv from
NOT 17:10:40.645283 TFTP: [31]:Error --> File not found
NOT 17:10:40.648431 SYSMSG: pid 31 (/sbin/tftpd) Normal Exit, status = 2
INF 17:10:40.648508 runtime = 0.020 secs

INF 17:10:40.648557 user cpu = 0.001791842 secs

INF 17:10:40.648603 system cpu = 0.005940506 secs

INF 17:10:40.648644 child user cpu = 0.000000000 secs

INF 17:10:40.648681 child sys cpu = 0.000000000 secs

INF 17:10:40.648725 sys interrupts = 0.000726440 secs for 7 interrupts

INF 17:10:40.648771 total cpu = 0.007732348 secs ( 0% utilization )

NOT 17:10:40.654098 SECD: ctlRequestFile: tftp Status 2 rcv’d
NOT 17:10:40.655363 SECD: updateCTL: finished CTL update
ERR 17:10:40.656271 SECD: EROR:updateCTL: ** had NO CTL and CTL tftp FAILED** tftp-err 2
WRN 17:10:40.753991 SECD: WARN:getCTLInfo: ** phone has no CTL
NOT 17:10:40.766877 tftpClient: tftp request rcv’d from /usr/tmp/tftp, srcFile = SEP0022555CFA78.cnf.xml, dstFile = /usr/cache/SEP0022555CFA78.cnf.xml

This is what is displayed for Status Messages:

10:16:49p TFTP Error : scratchpad/SEP0022555CFA78.cnf.xml
10:16:49p TFTP Error
10:17:20p File Not Found : CTLFile.tlv
10:17:20p No CTL installed
10:17:20p TFTP Error : scratchpad/SEP0022555CFA78.cnf.xml
10:17:20p TFTP Error
10:17:51p File Not Found : CTLFile.tlv
10:17:51p No CTL installed
10:17:51p TFTP Error : scratchpad/SEP0022555CFA78.cnf.xml
10:17:51p TFTP Error

FreePBX itself does not provision the phone. You have to use the Open Source Endpoint or the Commercial (paid) one in our App Store.

I also suggest you install the FreePBX distro over Asterisk Now. The official distro supports all features of FreePBX.

You also need to make sure your DHCP server is set to hand out your tftp IP in Option 66.

Thanks for the info.

I have installed and am running OSS Endpoint. I have Option 66 setup. As can be seen from the logs the phone is requesting the files.

What advantage does FreePBX distro offer over Asterisk Now?
Can I install over the top of Asterisk Now?
Keep in mind, I am NOT a Linux person :slight_smile: Give me CPM/MPM, TurboDos, DOS I am fine, Linux I am learning!

The FreePBX distro gives you access to our app store, is maintained by the FreePBX development staff, has consistent sponsorship and is always current.

Those are not tftp log messages from Linux so was not sure. Really need to see the phones log output.

TurboDos is a 30 year old operating system. I was running TurboDos clusters on 16bit S-100 cards in the early 80’s. Not sure how that is even in the least bit relevant. I cut my teeth on CP/M so we started about the same time. I was also using system V Unix then SCO Unix, FreeBSX, Non-Stop UX and finally Linux. So what have you been doing for 30 years stay relevent or the kids will put you out to pasture with a box of depends and a Kaypro II.

BTW in deference to my CP/M legacy I use a Linux text editor called Joe that still uses Wordstar cursor commands. Some habits never change.

Some of the logs I posted were from the tftp output.

Actually none of this is relevant, but it sometimes helps when a newbie to Linux isn’t just a total newbie :slight_smile:

Yes, some habits never change. I started in 1978 with a TRS-80, 4k memory and tape drive. I was one of the larger Kaypro dealers when they were still around! I still have a few Kaypro IIs, Kaypro 10s and Kaypro 4s. I also was one of the top Epson computer dealers for the QX-10. I even have an Altair 8800, and a couple of Smoke Signal SS-50 computers laying around. I ran an IMS S-100 with four 4 port cards and TurboDos that ran my 3 computer stores in Fort Worth and Dallas.

In 1995 I started an ISP and sold it in 2009. Since then, retired, do a lot of traveling in our motorhome and do volunteer work for non-profits, churches, church camps and etc.

I think I still have a copy of the Wordstar .93 diskettes!

QX-10 hacked up CP/M Valdoc’s if I recall. Z-80 and the max 64k of memory, the max and 8bit address bus can support. MP/M and T-DOS used bank switching.

It’s all unimaginably slow.

If you had an Imsai and a nice Z-80 CPU, FD controller and a memory board I would be very interested in a super trade.

Some CP/M highlights of my career. Worked for a Sanyo distributor in Miami then picked up a dealership when I moved to Tampa to go to College in 81. The MBC 1x00 series were great CP/M machines. I distributed a modified BIOS that supported HD’s (I ran a Corvus 5MB that was a bloody fortune) got the attention of Sanyo and ended up contributing to the US BIOS. Also ran the National Sanyo Users group RBBS on a CCS 3 slot S-100 system with 4 8 inch drives and later a 10M hard drive that NCR left on the college campus. Hand wired the controller.

I got into paging and later cellular and networking was always around. I started a small ISP in 1998, we converted all the dial up nodes to IP telephony POP’s about 5 years ago. I too I am growing recurring revenue and looking to get out in the next 5 years.

Putz around in the airplane and see the country at our own speed with my wife.

Anyway…Enough reminiscing. Get me phone logs please.

I may have an Imsai with Z-80. It may be a while before I can dig through the semi-trailer the stuff is stashed in.

I posted a log from the 7941G in post #2. Not sure what else I can provide, but point me to it!

An Imsai 8080 with the front panel and the toggle switches intact in reasonable shape?

We need to chat tomorrow. I can certainly get your phones working.

I believe I do have one. I don’t remember what is in it but it should be complete.

I will be headed over to Dallas tomorrow for a Royal Rangers conference and will be out all next week until Saturday evening. When I return back to home I will only be here a couple of days, probably leave on the 19th to go back to Arkansas to continue my work on their wiring of two new buildings and moving their equipment from their temporary offices. This is a Arkansans Teen Challenge. They had their 3 year old two story office building blown down by a tornado in 2011 and they recently had the shells for 2 buildings complete. I am on a MAPS RV team that works on churches, church camps and other non-profits as a volunteer. They have 14 buildings on campus and my task is to wire the two new buildings (almost complete) and hook up the entire campus with phones and network.

I will be back in Texas sometime in April hopefully!

Is there a way to PM on this system?

I GOT IT! It had to do with permissions on the tftpboot folder. Not 100% sure what they need to be set to, but since the server is on a none natted private IP and behind my firewall I just set the permissions to 777. Now that I know it was a permissions problem I will look for the proper permissions to set the director to.

There were a couple of problems with the SEP file that was created by OSS Endpoint but I am headed the right direction!

Cool, OK…I would still love to make a deal on the Imsai.

Good luck on your trip

I am back at trying to get the Cisco 7941G phones up and running on Asterisk. I downloaded the lastest version of FreePBX Distro and wiped out the AsteriskNow installation.

I have Cisco 7941G, 7965G and Aastra 6753ii phones. All of the phones find the TFTP server, get the IP info and download the firmware that I have specificed.

None of the phones complete the registration process. I have verified the passwords match. However, I get an error in the Asterisk Log file when I reboot the phone that states “NOTICE[8912] chan_sip.c: Registration from ‘sip:[email protected]’ failed for ‘’ - Wrong password”

What am I missing?

TRS-80...hmmm couldn't afford that, started with an MC-10 with 4k of RAM, added the memory expansion pack to get it up to 20k, coupled with a cassette tape drive, and thought I was real big time when I added the thermal printer.  Never could get the modem option, used to pretend I had one, by unpluging the output of the speaker on the cassette drive, and listening to the audio.

Still like to practice my BASIC "coding skills" on the MC-10 JavaScript Emulator




I finally found the problem. FreePBX Extensions was creating a 16 octet password, which was not being accepted. I manually put in a password, currently 9 digits, and all the 7941g phones booted up and are not registered. Still have not got the 7965g phones running yet.

i found this out the hard way lost about 2hrs before i shortened the passwords. if you need working tftp with optimum firmware and working config for 7965g let me know 6 years stable.

Thanks for the offer. I PMed you my email address.