Cisco 7940 Phones not registering after upgrading to FreePBX 2.9 with installation from FreePBX Distro

I am currently running the most recent version of FreePBX Distro, freshly installed just two days ago. The system is on a static IP, open to the public, with all ports open currently for diagnostics. I have two Cisco IP Phones model 7940 with firmware version POS3-07-00. I had the phones working on a freepbx 2.7 system but when I upgraded it is not working. I have tried everything and have googled and cannot find anything. Anyone have any ideas? Thanks in advance!!

What version of Asterisk are you running?

I am running asterisk version 1.8. I have version 1.6 running with freepbx 2.7 on another system and the phones work fine, can’t figure out why they won’t work with asterisk 1.8 and freepbx 2.9.

What version of asterisk 1.8 are you using.

I am running version

Hi, I believe there is a bug in Asterisk 1.8.4 with Cisco phones failing to register.

Ward Mundy has written about this a good bit on his blog and a few other folks have as well.

My understanding is that an earlier version of Asterisk 1.8.3 has no problems and the fix has been included in 1.8.5RC.

Others may have more updated information or fixes, but I noticed no one replied to you so wanted to share.

I am having the same issue with FreePBX-Distro and Asterisk, so I don’t think they have fixed it.
Looking at downgrading Asterisk or switching to a different distro. I wonder is AsteriskNOW has the same issue.

After upgrading one of our 7960 phones to a newer firmware seems to have fixed our issue.