Cisco 7940 and 7960's don't register via chan_SIP

I’m configuring a new Freepbx server to replace an asterisks server. As part of this I need to make it work with a lot of old Cisco CP7940’s and CP7960’s and I believe some old Digium phones though I’m not sure of the models for those currently. I’ve dug through all the forum posts I can find and most of what I’m seeing is “set NAT correctly” which when changing this it got the phone calling outbound locally and externally. I also set the SIP password short (8 characters). This didn’t fix the outbound like it did for some.

Hopefully helpful information:
Freepbx version -
Asterisk version - 18.17.1
CP79xx firmware - P0S3-07-3-00 (I have access to very few firmware versions and this is the only one that’s reliably worked well)

So far logs haven’t shown anything useful, incoming calls (from local PJSIP extension) just goes directly to unavailable.
The log is too long to paste here… if you have a better way for me to post that let me know and I’ll provide it. Also if there is a specific verbose/etc that would make the log more useful let me know and I’ll apply that.

Thank you for any assistance!

Paste the log at and post the link here.

Why aren’t you using pjsip for these phones?

I wanted to use PJSIP but it was working even less than SIP. From all the research I did no ones been able to get the old cisco’s working with PJSIP, but if you know how please let me know!

Here is the pastebin - Freepbx Logs -

I can say from an Asterisk perspective that Cisco phones work with PJSIP, provided all the NAT stuff is disabled on the endpoint. Same as chan_sip.

I set the extension back to PJSIP for testing and now it doesn’t call out again. From what I can find there aren’t NAT settings on the extension or in “Asterisk SIP Settings>PJSIP”. If you or someone else know what needs changed here it would be very appreciated!

For the extension, Rewrite Contact and Force rport should be No.

Does the phone register ok? If not, at the Asterisk command prompt type
pjsip set logger on
and paste the Asterisk log for a registration attempt.

If registration is ok, paste the Asterisk log for an outgoing or incoming call attempt.

Beware that Apply Config (or other reload) turns pjsip logger off, so turn it back on before making your test registration or call.

This worked to set to PJSIP - turn, Rewrite Contact and Force rport to No in the “Advanced settings” of the extension settings.

Thank you very much for your help!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.