Cisco 7912G (SIP) change AudioMode

I know this is not the place to ask for Cisco phone help but I really need help!! :slight_smile:

I have a Cisco 7912G phone connected to my PBX in a Flash setup. Everything is working great except audio. When I call someone, I can’t hear them until I make a noise on my end. Same when receiving calls; I can’t hear them until I make a noise (say hello).

I know it is not my Asterisk box causing this problem b/c I configured my phone to connect directly to CallCentric and I still experienced this problem. I think it has to do with the AudioMode. I read somewhere on the internet that someone had this same problem until they changed their audio mode from 0x00000011 to 0x00000010. However, I do not know how to do this. I can load the phone’s webpage on my network, but I don’t see a way to edit it. I also know there is someway to tell the phone the password via some config file, but I do not know which one…

Does anyone have any idea?? Thank you sooo much!!!

Cisco provides a tool to convert these setting files to binary format. The new file you created, did you convert the text file to binary format? I am assuming you would have, because you had already created a settings file for the phone to connect to Asterisk.
All you need in the new file would be:


Maybe that’s what you did. If you use a sample file (which you said you did not have), the default value in there is UIPassword:0, that’s why I indicated that you had to change the 0 to 1234.

My phone had SCCP initially. I got the SIP firmware package, which included some sample settings files and the firmware. I put the gkdefault.cfg file and the new firmware file into the TFTP folder and rebooted the phone. The gkdefault.cfg file had the firmware upgrade parameters and the UIPassword:1234 parameter already in it, so that’s how I gave mine the password, but I know the gkMAC.cfg (actaul mac address, as you did) should work as well, because the sample file has the UIPassword in there.
I had some problems initially though, because the phone menus were in French, so I reset the phone from the menu and that changed it to English. I had to give it a few reboots till it eventually upgraded the firmware. It could have been because initially I didn’t know how to point it to my TFTP IP address. The password was changed on the first reboot though.

Let me know how it goes.

Thank you so much!!! I’m still a little confused on the gkMAC.cfg (replaced MAC with actual mac address) file… I put it in my tftpboot folder. However, I don’t have the sample file that came with the firmware, so I just created a new file with

Change it to:

only. I reset the phone and nothing happened…

Thank you again for your continued support!!! :slight_smile:

There are two ways to do that:
First method: I did it through web interface, but in order to get the Apply/Submit/Save button, you have to give the phone a password, because without the password, the web interface is disabled (no button). If you used the sample configuration file that came with the firmware to get this phone to connect with Asterisk, you should have this entry in that file, if you didn’t, simply copy and paste this into your config file:

Change it to:

Reboot the phone and your web interface will now be active. I would use the gkMAC specific configuration file and not the general gkdefault.cfg file to assign the password, because that would modify your other Cisco phones as well (I bet you knew this, but in case you didn’t).
Now, in the web interface under Audio Parameters, you can change AudioMode from 0x00000011 to 0x00000010. (This disables silence suppression, as that is what causes your problem). Save and reboot.

If you change your password in the web interface after, you should take that (UIPassword) entry out of the config file, because if you don’t, it will change the password back to 1234 every time you reboot. Also, if you use the phone menu, and go to Network Configuration, and press **# to unlock the menu, the phone will ask for the password you assigned to the phone.

Second method: I didn’t try this one, but it should definitely work. in your gkMAC config file, again, if you used the sample file you should have this entry, if not, copy and paste it into the file:

Change to:

Reboot the phone and it should fix your problem.

Hope this helps.

Thank you for your reply!

How exactly did you do this? I have two other Ciscos (7941 & 7911) setup with the TFTP server and stuff, but this phone is older and isn’t “XML compatible,” whatever that is called.

Do you have a copy of your configuration file?

I can’t update the phone from the web interface… There is no submit/save button on any page.

Thank you!!!

I don’t know if you found a solution yet, but I think the following link will help you. Read the first paragraph of the Audio Parameters section:

I did this before I even tested my phone, and it works fine.

I have the same issue you are facing with my 7912G.
I have 15 SIP phones upgraded to CP7912080001SIP060412A.
In the firmware folder i have the following files: bmp2logo,cfgfmt,gkdefault.txt,gkdefault.cfg and sipexample.txt.
I want each sip phone to retrieve its config from the tftp server on startup.
1-I created a tftp server lets say on debian machine with root folder /srv/tftp/Sip and added all the files in that folder.
2- i have one sip phone mac address: 000E38412C8F
so i renamed the sipexamplefile.txt to gk000e38412c8f.txt
Modified the config files like i want and in the tftpURL field i
pointed the path as the following
and compiled it to binary using this command:
cfgfmt -g -tsip_ptag.dat gk000e38412c8f.txt gk000e38412c8f
3-when i reboot the sip phone, it is taking the local config on the phone and seems the unit is not communicating with the tftp server.

Please advise what i did wrong? (a step by step example will be highly appreciated)
If possible to give the correct path format if the tftp is on window machine as well.

Best Regards