CID Superfecta - GooglePlaces

I have a valid API Key for GooglePlaces, I pasted that in, and click on Yes to “I Agree”, then click the Save button. After that, I get a red box from Whoops that says:

Undefined index: Google_Agreements

It does not seem to accept it, and GooglePlaces is not configured in CID Superfecta.

Are you using FreePBX 13?

Yup, 10.13.66-5. All updates installed.

Adding that it does save my API Key, but it doesn’t seem to want to accept the I Agree option.

I can reproduce this:

  1. Add Google places to a superfeacta scheme. (click yes next to it on the list)
  2. Click settings for Google Places
  3. Click Yes in the box that comes up.
  4. Click Save in that box

As a check, the cache source saves changes fine.

Would it be best to file a bug report?

Bug confirmed.

The file:

has two parameters that do not play nicely with the current version of Superfecta. Changing the type from ‘info’ to ‘textarea’ will get things working in the near term until we can figure out how to display the necessary TOS.

Report filed: