CID Name Prefix lost for anonymous callers

In inbound modular, there is a set-up for CID prefix. For example, I created “Home-“ for my family DID and “John-" for my home office DID. However, when an anonymous callers call any of the DIDs, the freepbx failed to pass on the corresponding prefix to the extension and the screen shows “Anonymous” which give me not hint on which DID the caller dialed.

This issue occurred in freepbx version 2.2. I posted a bug report and it was fixed in 2.3. Now, it appears in 2.4. (I just posted a bug report).

I don’t see the bug report, can you check and give a pointer to it, and include a CLI trace, verbosity 5, of the incoming call that this is exhibited on so we can see why the regression occurred on your system.

Hi,

I’m having the same issue.
CID name Prefix is lost when receiving calls from anonymous.
I’m also using FreePBX 2.4.0.0

Here is a call trace:

— snip —
– Accepting voice call from ‘’ to ‘65062012’ on channel 0/1, span 1
– Executing [[email protected]:1] Set(“Zap/1-1”, “__FROM_DID=65062012”) in new stack
– Executing [[email protected]:2] GotoIf(“Zap/1-1”, “1 ?cidok”) in new stack
– Goto (from-pstn,65062012,4)
– Executing [[email protected]:4] NoOp(“Zap/1-1”, “CallerID is “CID withheld” <>”) in new stack
– Executing [[email protected]:5] Set(“Zap/1-1”, "_RGPREFIX=LL: ") in new stack
– Executing [[email protected]:6] Set(“Zap/1-1”, “CALLERID(name)=LL: CID withheld”) in new stack
– Executing [[email protected]:7] Goto(“Zap/1-1”, “from-did-direct|4412|1”) in new stack
– Goto (from-did-direct,4412,1)
– Executing [[email protected]:1] Macro(“Zap/1-1”, “exten-vm|novm|4412”) in new stack
– Executing [[email protected]:1] Macro(“Zap/1-1”, “user-callerid”) in new stack
– Executing [[email protected]:1] NoOp(“Zap/1-1”, "user-callerid: LL: CID withheld ") in new stack
– Executing [[email protected]:2] Set(“Zap/1-1”, “AMPUSER=”) in new stack
– Executing [[email protected]:3] GotoIf(“Zap/1-1”, “0?report”) in new stack
– Executing [[email protected]:4] ExecIf(“Zap/1-1”, “1|Set|REALCALLERIDNUM=”) in new stack
– Executing [[email protected]:5] NoOp(“Zap/1-1”, “REALCALLERIDNUM is “) in new stack
– Executing [[email protected]:6] Set(“Zap/1-1”, “AMPUSER=”) in new stack
– Executing [[email protected]:7] Set(“Zap/1-1”, “AMPUSERCIDNAME=”) in new stack
– Executing [[email protected]:8] GotoIf(“Zap/1-1”, “1?report”) in new stack
– Goto (macro-user-callerid,s,13)
– Executing [[email protected]:13] NoOp(“Zap/1-1”, “TTL: ARG1: novm”) in new stack
– Executing [[email protected]:14] GotoIf(“Zap/1-1”, “0?continue”) in new stack
– Executing [[email protected]:15] Set(“Zap/1-1”, “__TTL=64”) in new stack
– Executing [[email protected]:16] GotoIf(“Zap/1-1”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,23)
– Executing [[email protected]:23] NoOp(“Zap/1-1”, “Using CallerID “LL: CID withheld” <>”) in new stack
– Executing [[email protected]:2] Set(“Zap/1-1”, “FROMCONTEXT=exten-vm”) in new stack
– Executing [[email protected]:3] Set(“Zap/1-1”, “VMBOX=novm”) in new stack
– Executing [[email protected]:4] Set(“Zap/1-1”, “EXTTOCALL=4412”) in new stack
– Executing [[email protected]:5] Set(“Zap/1-1”, “CFUEXT=”) in new stack
– Executing [[email protected]:6] Set(“Zap/1-1”, “CFBEXT=”) in new stack
– Executing [[email protected]:7] Set(“Zap/1-1”, “RT=”””) in new stack
– Executing [[email protected]:8] Macro(“Zap/1-1”, “record-enable|4412|IN”) in new stack
– Executing [[email protected]:1] GotoIf(“Zap/1-1”, “0?2:4”) in new stack
– Goto (macro-record-enable,s,4)
– Executing [[email protected]:4] AGI(“Zap/1-1”, “recordingcheck|20080417-171538|asterisk-1208445338.2”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
– AGI Script recordingcheck completed, returning 0
– Executing [[email protected]:5] NoOp(“Zap/1-1”, “No recording needed”) in new stack
– Executing [[email protected]:9] Macro(“Zap/1-1”, “dial||tr|4412”) in new stack
– Executing [[email protected]:1] GotoIf(“Zap/1-1”, “1?dial”) in new stack
– Goto (macro-dial,s,3)
– Executing [[email protected]:3] AGI(“Zap/1-1”, “dialparties.agi”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi
dialparties.agi: Starting New Dialparties.agi
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Manager ‘admin’ logged on from 127.0.0.1
dialparties.agi: Caller ID name is ‘LL: CID withheld’ number is 'unknown’
dialparties.agi: USE_CONFIRMATION: 'FALSE’
dialparties.agi: RINGGROUP_INDEX: ''
dialparties.agi: Methodology of ring is ‘none’
– dialparties.agi: Added extension 4412 to extension map
– dialparties.agi: Extension 4412 cf is disabled
– dialparties.agi: Extension 4412 do not disturb is disabled
> dialparties.agi: extnum 4412 has: cw: 1; hascfb: 0 [] hascfu: 0 []
> dialparties.agi: ExtensionState: 0
– dialparties.agi: DbDel CALLTRACE/4412 - Caller ID is not defined
– dialparties.agi: Filtered ARG3: 4412
== Manager ‘admin’ logged off from 127.0.0.1
– AGI Script dialparties.agi completed, returning 0
– Executing [[email protected]:7] Dial(“Zap/1-1”, “SIP/4412||tr”) in new stack
Extension Changed 4412 new state Ringing for Notify User 4411
– Called 4412
– SIP/4412-087449b8 is ringing
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Manager ‘admin’ logged on from 127.0.0.1
== Manager ‘admin’ logged off from 127.0.0.1
– Channel 0/1, span 1 got hangup request, cause 16
Extension Changed 4412 new state Idle for Notify User 4411
== Spawn extension (macro-dial, s, 7) exited non-zero on ‘Zap/1-1’ in macro ‘dial’
== Spawn extension (macro-dial, s, 7) exited non-zero on ‘Zap/1-1’ in macro ‘exten-vm’
== Spawn extension (macro-dial, s, 7) exited non-zero on ‘Zap/1-1’
– Executing [[email protected]:1] Macro(“Zap/1-1”, “hangupcall”) in new stack
– Executing [[email protected]:1] ResetCDR(“Zap/1-1”, “w”) in new stack
– Executing [[email protected]:2] NoCDR(“Zap/1-1”, “”) in new stack
– Executing [[email protected]:3] GotoIf(“Zap/1-1”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,6)
– Executing [[email protected]:6] GotoIf(“Zap/1-1”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,9)
– Executing [[email protected]:9] GotoIf(“Zap/1-1”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,11)
– Executing [[email protected]:11] Hangup(“Zap/1-1”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on ‘Zap/1-1’ in macro ‘hangupcall’
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on ‘Zap/1-1’
– Hungup ‘Zap/1-1’
— snap —

Thanks in advance

Regards,
KriS83

#2763

Hi, Philippe, the new trixbox 2.6.1 which has FreePBX 2.4.x version has this problem. I just submitted a bug report #2850.

rogerluo,
this should have been addressed in the latest core module update that was recently published. Please confirm back at the ticket so I can close it or if not, please provide the requested traces there. Thanks.

Philippe,

You are right. The new upgrade solved this problem.

Thanks.
Roger

I’m experiencing this issue in the above version. Do I need to upgrade to 2.4? Thanks.

Joe

Yes, you do.

I have encountered the same problem at the moment. Can any help ?

Version:
Elastix 2.0.0-36