CID Name Prefix is not working in Ring Group Module

My CID Name Prefix is not working in Ring Group Module. I have installed even latest 2.2 version of the elastix and tried to get the calls through Ring Group but it does not show the CID Name Prefix as it just show the caller number only and does not show caller’s name. When I receive the call on my cell phone which I have forwarded through Ring Group, it does not show the caller’s name and number. It shows only the caller’s number even at the place where it should show the caller’s name and also beneath that again it shows the caller’s telephone number like in this format (Suppose caller’s telephone#123-123-1234):


I will appreciate if anybody can advise me how to fix this problem so that the CID Name Prefix start working so that I may start knowing before blindly picking up the calls, how is calling? Any Idea or any hint will be appreciated…

Anyone has any idea???

CID Prefix will add the data entered to the CNAM and then pass it to the phone. This should work for VoIP phones or phones connected via an ATA but CNAM is not (can not) be passed to cell phones. They only receive the CID from the carrier and populate the name from it’s (the phones) local DB.

Does this make sense?

Thanks Guys for your replies. It seems to be that at wireless phones only numeric CID can be done as per the two replies which my friends are saying and I am 100% agree with them. But here the wireless phone company which I am using, is showing the caller name and phone number as well like the land lines or phone connected through ATA. If I directly transfer the call to my wireless phone from inbound rout and put their CID Name Prefix, it shows on my wireless phone (CID name + numeric) but when the same I do through Ring Group and put CID name there, it does not show on the wireless phone. I think something from the development side should be change or amend as it works from the inbound rout module but does not work from the Ring Group module or may be I am doing something wrong. Please advise if anybody has any idea…any comment…

I’m using freepbx with elastix v2.2, i setup the ring group with CID Name Prefix just for 3 letters like CAN- and call is forwarded on my cell phone, call goes through properly but its not passing through CID Name Prefix from ring group.

any help will be highly appreciated…
thanks in advance…

Wireless phones can only do numeric CID.

yes but the name is handled by your carrier. They ignore any name you send and put their own in. CID prepend only works for internal phones not external phones like cell phones.

Thanks Tony for your response. Actually you are right but here in my case, the cell phone company, which I am using is showing the caller’s name and phone number both in the following format when I receive the call at my cell phone:


Just like a land line or phone attached with the ATA and showing the caller’s ID. Even when I forward my phone number directly from Inbound Routes to my cell phone and put any name in-front of the CID Name Prefix area, it works fine and it shows at my cell as well.
For example, if I put the name “SALE:” as a CID Prefix Name through Inbound Routes modul and then directly forward it to my cell phone it works fine. I receive the calls at my cell phone and the caller’s ID shows in this way:


But this does not work at all through ring group. I receive the calls but CID Name Prefix does not work there at all and it just shows the caller’s ID in this format:


It does not show the caller’s ID or even CID Name Prefix (SALE). My problem is, if it is showing through Inbound Routes, the correct CID Name Prefix why it is not showing through Ring Group module? Is there anything which I need to do to fix this problem? Any suggestion…any idea…?

Yes that is because FreePBX only does the prefix in ring groups and follow me and such to local phones. That is what we all keep telling you. Because in the past lots of carriers would actually reject the call if you tried to send a Caller ID Name so we put in logic in FreePBX to not prepend the Caller ID for external calls.

Thanks Tony for your advise and guidance. I really appreciate what you have advised me. Could please guide me with any script or command if I want to over-write it so that I can try on my system once. Might be, I achieve my desired results from the system by having run this script or command at my system and can get at my cell phone CID Name. I only want to update this command in ring group module as in Inbound Routes, the CID name prefix given, is working absolutely fine and shows the caller ID on my cell phone.

Hi Tony…Any more help please…

Their is no command or script. It is done in all the dialplan and macro logic. Not sure where to direct you.

Hi Tony
I just have upgraded my system and now I am facing with another problem and the problem is that I receive the calls on my cell phone through ring group but there is no audio. The caller can not listen my voice and same I am unable to listen the caller’s voice. I have checked everything but not sure why is this doing like this? Both (caller’s and receiver) can not make conversation as there is no audio. I receive the calls at my cell phone properly but without voice/audio. Please help me here that what I have done wrong or what I need to change/upgrade. Thanks in advance for your help…

I chuckle when people say “I have checked everything” but it still doesn’t work.

“Checking everything” is meaningless unless you tell us what you checked.

No audio on ring groups is caused by the trunk reinviting the media off the box. Usually can be fixed by changing SIP reinvite behavior.

Since you did not tell us your FreePBX version or trunk info I can’t suggest anything further.

Hi Skyking
I am using two different with elastix v2.0.3 with freePBX v2.7.0.10 and the other one with elastix v2.2.0 with freePBX v2.8.1.4 for two different offices. Same type of problem I am facing at both systems. Could you please guide me what to fix or how to fix?

Anybody has any idea how to fix the problem of audio as I am getting the calls at my cell phone through ring group but both sides (caller and receiver of the call) can not listen the audio. No audio at all through ring group transferred calls at cell phone. Any advise…?

I was using it before at elastix v2.0.3 and it was working nicely but has just upgraded to v2.2.0 and now it is not working. I receive the calls at my cell phone and the cell phone rings but when I pickup the call, there is not audio. I will appreciate if someone can suggest me what I have done wrong and any other suggestion…?

If anyone else has ever came-across with this kind of problem (no audio through ring group). If yes, how the problem was solved…? Please advise…

You to disable SIP reinvites

Read step #8 of these instructions: