CID and cnam lookup

Disclaimer: Please excuse my ignorance on this topic.

We’re on FreePBX with Asterisk 11.20.0

I’m trying to toubleshoot a CID issue. For one of our numbers, we’re seeing a caller ID name “Person’s Name”. But when I use opencnam’s url to test the number it says something totally different, which is what it should be saying.

Question is, how can I tell where freepbx/asterisk is getting the incorrect name “Person’s Name” for that number from? Is there a way to tell what source it’s pulling from? What’s interesting is, we have of CID turned off, but names are displaying on our phones anyway (perhaps being passed from the carriers).

Check your Asterisk Phonebook for an entry, it could be in there. Without knowing what you are pointing your CID lookup to, which is within your inbound route for the DID, it is hard to say.

CID can be passed from the trunk provider if the service is offered, if you have it turned off and you are still getting a name, it is cached in your DB somewhere, was you using CID SuperFecta by any chance at any point?

Thanks for the info. So nothing in the Asterisk Phone book.

The inbound route settings are: CID Lookup Source->Source: None, and Superfecta CID Lookup->Enable CID Superfecta: (no checked), Scheme:ALL.

I don’t think we were ever using CID. How can we check the DB for the cached record and clear it?

We’ve noticed recently that we’re getting CID on multiple PBX servers we have (all with Anveo Direct as the provider), so they are probably being passed from the trunk. Is there a way to set the trunk/peer settings to disable this or at least make a permanent modification of certain CID’s that are wrong (probably by editing the Asterisk Phonebook?)

Update: I made an Asterisk Phonebook entry for the problem number, then added an “Internal” Caller ID Lookup Source under that module, and then selected that source on the inbound route for the receiving sides DID. This is now overriding the CID that seems to be coming from Anveo Direct. The only problem with this is that you have to go to each inbound route and change the CID source to the Internal one made. I can’t find a way to apply it to the entire trunk.

If it is an issue, I would call your provider and ask them to check the number. I doubt your pbx will cache the number without the option being enabled… I know CID Superfecta can cache results, hence the question.

It would seem the trunk provider is providing you bad data, they are the ones that pass the CID info onto you, but I really do not know the ins and outs of the way it works.

I use Sipstation for my trunks, CID has always been good, but if missing I use CID Superfecta to do the leg work.

So I contacted Anveo and they said their provider, which is, seems to be passing CID for free right now, so that’s why we’ve suddenly noticed CID info being shown even though it isn’t enabled in FreePBX (nor is the paid lookup option on Anveo selected).

They told me the number also does not have a cnam entry, so they told me how to add one for $5 through their API. I went ahead and did it with a different DID as a test, but the free lookups out there aren’t showing anything yet. We’ll just have to wait and see I guess…