Chanspy : No audio from spied channel, but I cant talk to it

Hi !

I have an issue that I really do not understand.

I have User A who’s in a conference (with confbrige).

Now I want user B to be able to spy on user A and talk to him with Whisper or Barge depending if I want the spy to talk only to A, or also to the external calls that A may make.

So to do so, I’m getting A’s channel (that I can find on the CLI using “core show channels concise”, and I do the following on B’s side to start the chanspy :

same => n,ChanSpy( USER A CHANNEL ,B)

When it is done, User B (The spy) can talk to A, and A can hear B. BUT, User B can’t hear A ! It feels like we’re using the “private whispering mode” when the spy can talk but can’t hear, but it is not the case here as I’m using the “B” parameters.

I also noticed something strange. Without the “q” parameters, the spy is supposed to hear some sounds when the chanspy begin. I can confirm this on the logs :

– <SIP/131313-00000022> Playing ‘beep.ulaw’ (language ‘en’)
– <SIP/131313-00000022> Playing ‘spy-sip.ulaw’ (language ‘en’)
– <SIP/131313-00000022> Playing ‘digits/1.ulaw’ (language ‘en’)
– <SIP/131313-00000022> Playing ‘digits/2.ulaw’ (language ‘en’)
– <SIP/131313-00000022> Playing ‘digits/1.ulaw’ (language ‘en’)
– <SIP/131313-00000022> Playing ‘digits/2.ulaw’ (language ‘en’)
– <SIP/131313-00000022> Playing ‘digits/1.ulaw’ (language ‘en’)
– <SIP/131313-00000022> Playing ‘digits/2.ulaw’ (language ‘en’)

But I never hear these sounds. Like if they were played on a different channel or something. This is probably related to the issue I’m having.

Details about the setup :

  • Both user are using WebRTC using sipML5, everything else is working fine (making outgoing call, etc)
  • I’m using Freepbx with Asterisk 16
  • Both extension are using SIP, I tried with PJSIP with the same result.

I can’t wrap my head around this.

Thanks for your help !

You might try turning on RTP debugging to find out where your streams are going: rtp set debug on

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.