Changing sound language

configuration
Tags: #<Tag:0x00007f7028a89b08>

#1

I have FreePBX set up and things like voicemail announcements were in English. I downloaded the files in my language and replaced the files in the “en” directory (/var/lib/asterisk/sounds/en) which works great. I guess this is not the correct way, which would be to create a new directory with the correct ISO code for my language, place the files in that directory and change the language of the system. The problem is, I can’t seem to find the language setting.

Can anyone tell me where to change this setting?


#2

Start with

https://wiki.asterisk.org/wiki/display/AST/Sound+Prompt+Searching+based+on+Channel+Language

That path will be used by asterisk to search for a usable sound file based on the “Language” of the current “channel”, I am not sure if you can do it in the GUI (I looked a bit in FreePBX 11 ) but editing /etc/asterisk/asterisk.conf to reflect

defaultlanguage=nl

should clue asterisk where to start looking without individually setting extensions, inbound routes etc. to your language of choice


(TheJames) #3

http://wiki.freepbx.org/display/FPG/Sound+Languages


#4

Is that available in FreePBX 11?


(TheJames) #5

did the user say he is on 2.11? Why would you ask?


#6

Because it is possibly relevant or should we assume that everyone uses FreePBX 13?

It was a simple question, Is it available in FreePBX 11?

edit :- actually I generally use FreePBX 12 (mea culpa) , so is it available in FreePBX 12?


(TheJames) #7

This is a 13. feature. That said no one should be on 2.11 at this point. Everyone should be on 12 at a minimum with a plan to migrate to 13. We have 14 in progress which will drop 12 support to security only.


#8

So if it is not available in FreePBX 12 then you can as suggested, add

defaultlanguage=zz

to /etc/asterisk/asterisk.conf and FreePBX -13 will honor it, Am I correct?


#9

So basically I have to add defaultlanguage=zz to the file below?

Is that the only thing or do I need to reboot?


#10

That (changing the conf file) doesn’t seem to work.


#11

Got it working using the custom languages which @jfinstrom suggested. Thanks!


#12

Is your solution actually a global one or is it just for sip and iax2 channels?


(Floe Hetling) #13

If nothing helps, try reading my post here


#14

If that doesn’t help , read my reply