Changing IP addresses on network

Hello I’m setting up a new freepbx at home and moving it to my small office. The problem is my home network is a 192 address but my small office is a 10.1 address. I looked online to learn how i can change it when i get to work. But everything i found online i have tried and nothing works. What is the correct way of changing the ip address without having to reinstall everything? I’m installing the latest freepbx.

Joseph

The NIC config will be in folder /etc/sysconfig/network-scripts and probably called ifcfg-eth0. Edit with your new LAN details and then service network restart

Thank you. I’m trying to figure out why i have no network. I didn’t make no changes yet to the network. And yet i have no ip address. I tried to do a ifconfig and nothing i even try a ping of google or yahoo and nothing. But i know i have network i even see the network leds on and I’m getting blinking network leds. But yet no network at all.

Joseph

Please post the output.

Also, post the output of
netstat -nr

Does the directory /etc/sysconfig/network-scripts exist? If so, does it contain any files with names starting with ifcfg- ? If so, post the names and contents.

Since you have no network connectivity, post screenshots if that is easier for you.

Hello here is the screenshots.

20200307_224654_2

ifconfig screenshot?

I tried everything. I even put a external usb to ethernet adapter and i get the same thing.

20200307_230326

I took the network cord and pluged it into my laptop and disabled my wifi on it. I was able to get online with no problem. I know the Ethernet connection works.

but apparently the dhcp server, not so much

ifup eth0

?

Hello dick0
I have tried that too. I remember that from the old pbx setup. When i tried that nothing change, No luck. So what i did just for the heck of it i reinstalled freepbx again. For some odd reason that worked. I’m now getting a ip address.

This is strange.

Joseph

But what did the screen show as you “ifdown eth0” “ifup eth0” ?

I honestly don’t remember a little ticked off. So i reinstalled it. And somehow that woked,

Well, that’s one way :wink:

I’m just trying to figure out how that happen. I never saw that before. Not with linux or windows. Well with windows always missing drivers but always saw it there in device manger. But in linux i always saw a network connection. This was strange to see.

Edit ohh well it works it works lol

if you use ‘BOOT_PROTO=dhcp’ then ifup will show the attempts if/when they fail . . . .

IMHO all servers should be using ‘BOOT_PROTO=static’ and use an ‘address’ outside the DHCP servers ‘range’ in the network you are on using valid for netmask, address and gateway values.

1 Like

Thank you i will try that next time this hppens.

In the ifcfg file the onboot option was set to “no” which would prevent the interface from starting up.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.