Changing extensions number digits

I’m newbie in asterisk
I use asterisk 11.1.2 via PIAF under VMWARE and Freepbx
My asterisk worked fine with 10 hard and soft phones over internet.
Yesterday I decided to reduce the numbers of digits of the extensions from 4 to 3 (the dialplan had to be corrected for the project to interconnect my asterisk with other asterisks via IAX)
So I delete the extensions (1004 to 1013) and create the same with 3 digits (removing the second digit) from 104 to 113

I applied the config and register the tels with their new ID

Since this modification (the asterisk was working fine and I dont make any other modification on my host and network) the RTP flow between 2 tels is working in one way only

I had to understand this situation and I would be glad to give some others informations if somebody in interesting by my topic
Thank you

FOP is a third party application. It’s not us. What version of FOP are you running.

You can’t possibly being doing RTP on 5004, look at /etc/asterisk/rtp.conf, unless you have changed it the system uses 10,000 - 20,000 by default.

Thanks, I’m going to try and I’ll give you a feedback

It should not be sending RTP on port 5060 or 5004 those are lower ports. Did you do the debug RTP as I described?

Plash Operator Panel shows the old extensions (with 4 digits)
It is not coherent
I do not use FOP, i do nothing with it and let the module admin set automatically FOP
Is asterisk in an instable state ? which is the cause of my problem

Ok test done
Phone1 send his packets to asterisk on port 5004 (OK)
But asterisk send these packets to the phone 2 on port 5062 (the phone can’t listen). It seems wrong, no ? Thanks

hello, yes I did
I show lines in the CLI console like
RTP Got …
RTP Sent …
I don’t remember exactly the syntax because I’m at home and not at my office
The IPs were right but the ports RTP were 5062 for one phone and 5004 for the other
5004 does not surprise me; my hardphones are Grandstream BUDGETONE 100 and the default port RTP in these phones is 5004, but I don’t explain 5062
I don’t understand this behaviour from a system working well before the modification of extensions

Have you read that I saw the old extensions remaining in FOP ?
Why the framework PBX does not keep coherence of extensions ?
Thank you

I can tell you your problem has nothing to do with changing the number of digits in your extensions. Did you change your NAT settings?

I assume the phones are not on the same network as the machine?

I can tell you your problem has nothing to do with changing
the number of digits in your extensions

That’s a point, thanks

Did you change your NAT settings?


I assume the phones are not on the same network as the

Yes, asterisk is on a DMZ protected by Sophos/Astaro FW
The phone are some on the LAN and some on the internet
I have the problem, even with 2 phones on the LAN
When phone 1 talk, phone 2 can listen
when phone 2 talk phone 1 can’t listen

The context of the situation was
I was testing call between 1004 (on the LAN) and 1111 on the internet (a new extension)
It was OK
So I said bye, i’m going to change your extension and mine
And after the change (no other action) the 2 phones can register well, but the issue happens (this is truth)

I can’t understand


Neither can I, make a call to a phone with one way audio, while in the call run an ‘rtp set debug on’ and see what IP Asterisk is trying to send media to.

Don’t forget to turn the debug off when done or you will have big logs.