Changing channel driver to both it reverts to chan_pjsip

I am trying to enable chan sip, when I Change channel driver to both it reverts to chan_pjsip. FreePBX 17 Beta on Debian 12, tried loading module chan sip, it failed

On my unmodified 17 beta:

*CLI> module load chan_sip.so
Unable to load module chan_sip.so
Command 'module load chan_sip.so' failed.
[2024-05-07 11:21:48] ERROR[1117506]: loader.c:283 module_load_error: Error loading module 'chan_sip.so': /lib/x86_64-linux-gnu/asterisk/modules/chan_sip.so: cannot open shared object file: No such file or directory

so it appears that Asterisk was compiled without chan_sip.

What device or trunking provider is not working with pjsip? Have you tried to determine why?

FreePBX 17 installs Asterisk 21 by default which no longer has chan_sip. To use chan_sip the Asterisk version has to be switched to an earlier version, like 18 or 20.

And just so people can follow this, it was filed on Github: Failing to enable chan SIP on FreePBX 17 Beta on Debian 12 · Issue #140 · FreePBX/issue-tracker · GitHub