FreePBX | Register | Issues | Wiki | Portal | Support

Changing chan sip default port 5060

configuration
Tags: #<Tag:0x00007fdf9c21f9e8>

#1

I have searched everywhere online but i haven’t been able to fully understand this, hopefully one of you freepbx gurus can help me.

Using hosted FreePBX 14.0.1.31 with asterisk 15 and polycom vvx310

To my understanding keeping the default 5060 port is not advisable due to it always being probed. So I try changing ports under Settings>Asterisk SIP Settings>Chan SIP Settings>Advance General Setting>Bind Port to 45xxx and tls bind to 44xxx. but i run into random intermittent registration issues when the office has power surges. in addition i do configure the service providers dashboard and change the settings to point correctly to the server as well as the phones, for example SERVERIP:45xxx. what is weird is that registration seems to be a hit or miss or it will register and have no inbound or outbound audio. in this case the systems were set and working for about 3 to 4 weeks except until the recent power outage which the phones would not reconnect to the server until i reverted all ports to 5060.

Is there something im missing? isnt the bind port the same as the registration port? or is there another setting im suppose to change?


#2

Many find sngrep to be a good analytical tool for sip conversations and sdp flows. It will help you to isolate and identify the call progression as it enters or leaves your system, to where it ends and why. That way “weird” and “hit or miss” will be identified more explicitlty


#3

thank you dicko i will try this next time im onsite. by weird i mean the phone just wont register to the sip server but once registered i think it has no problem having the listening ports changed, im guessing the freepbx looks for 5060 when rebooted for registration?


#4

That’s where sngrep can help you understand the why-for, try it . . . and absolutely never guess!! it will rarely work out in your favor :slight_smile: