Changed context=from-zaptel now cant make outbound


I am new to asterisk and free pbx. In order to handle inbound route DID’s seperatly I changed my dahdi-channels.conf to context=from-zaptel this acomplised what I set out to do however now when I try to make outbound calls I get bussy signal.


I read somewhere that from-zaptel only affects incoming.

So your problem is probably somewhere else.

Look at the log and see what’s the matter…

tail --lines=500 /var/log/asterisk/full --display the last 500 lines of the log.

And provide more info on your configuration.

Most likely when you changed from-zaptel, it may have lost your trunk definition of your outbound route. I would check your outbound route to see what trunk it is pointing to. You should not be manually configuring the config files. You should be doing this through the FreePBX interface.

Good point, blanchae, on the cause of the problem, but unless I am mistaken, there isn’t anywhere in FreePBX Version: 2.6. that allows you change context to from zaptel. In fact it tells you right there in the FreePBX config to do this (and I quote) :

"Zap Channel DIDs allow you to assign a DID to specific Zap Channels. You can supply the same DID to multiple channels. This would be a common scenario if you have multiple POTS lines that are on a hunt group from your provider. You MUST assign the channel’s context to from-zaptel for these settings to have effect. It will be a line that looks like:

context = from-zaptel

in your zapata.conf configuration effecting the specified channel(s). Once you have assigned DIDs you can use standard Inbound Routes with the specified DIDs to route your calls."

BUT this particular file zapata.conf does not have the warning (and I quote again) :
"; Autogenerated by /usr/local/sbin/genzaptelconf – do not hand edit
; Zaptel Channels Configurations (zapata.conf)"

This kind of stuff will drive you nuts if you let it, but remember the price and read up. Make your changes carefully, one at a time, and test them thoroughly. Document what happens and let the rest of us know.

I usually use FreePBX’s Config Edit option to make changes.

Here are the notes that I put together after reading several of these conflicting statements. If it makes you nervous, it probably should.

A number of .conf files may require editing to get asterisk to improve performance or for special configurations for individual requirements. The following website tells who owns what files in /etc/asterisk when FreePBX is installed:
NOTE: Config files manual tweaks in this guide are meant for advanced users. They should only be used when the FreePBX does not offer the setting needed. If you have read this far, you are probably an advanced user. Unless you have a compelling reason to do so, users are advised against any manual config file tweaks.

NOTE: Config Edit only gives access to the FreePBX files. If you need to edit other files, you should use a proper editor and terminal access to the server. You can use your own SSH client or the Java SSH provided by FreePBX.
The use of tools like Config Edit lead to problems with novice users especially that they present configuration files that should never be edited and novice users are not aware of these restrictions. Experienced users typically have no issues using an editor to access configuration files and can further benefit from smart editors that color code Asterisk and other configuration files (such as vim) as well as aid in other syntax related requirements in config files.
NOTE: NEVER manually edit a configuration file that does not have the word “custom” in the file name. There are a few minor exceptions -you can modify sip.conf and iax.conf to allow additional codecs. You can modify sip_nat.conf to resolve one-way audio problems. You can modify zaptel.conf to allow pointing channels to extensions. Any file with the word “additional” in it will be rewritten by the system every time you click the Apply Configuration Changes in FreePBX, and most other configuration files (except for the ones with “custom” in their name) will be overwritten every time FreePBX itself is upgraded.
Typically you must restart Asterisk every time you make changes to the config file.

The configuration files (.conf) reside both in the /etc/asterisk directory and /etc directories. Configuration files in the /etc/asterisk are generally editable through Config Edit.
To start editing the .conf files we need to select Tools tab, select the Config Edit selection from the dropdown menu as illustrated below.

Config Edit does not show all of the files that you can edit or view. If it does show the file and you need to look at it or edit it, it is better to use Config Edit than other tools, like the editor nano.

Thank you so much for the support. I am a new to this stuff. I actually did the editing under the guidance of Palosanto paid support. I did it through Elastix file editor. Was driving me nuts why I couldn’t route my ZAP channels. It should be easier in my opinion.

As per my current problem I figured it out. I only have one outbound route with a 9|. I tried a local route and it worked. I deleted my initial route and re-created it and now it works again.

Now on to e-mail will work on it tonight.


I made similar change, but still can not get the incoming call to route to DID. It seems not only dahdi_channels.conf need to be changed, extension.conf also have to be changed, this thing is so confused to me. I am so sorry.

Dear All,

I have the same problem with outbound calls after manual editing of conf file.

What to do now, how I can restore by pbx? I have no backups… =(