Change what is displayed on outbound call on SIP Phone (Caller)


(Joshua Cadman) #1

I have a few Mitel 5330 IP phones running SIP firmware as well as Grandstream IP Phones and when making an external call, the screen shows CID: (My external Number / CID) which then blocks the number I have dialled whilst on the phone. As A few times I have been on the phone I have needed to know the number I have been on to and not been able to due to it showing my caller ID. Is this possible to change to only display the number I have dialled instead of showing me my external number?


#2

Try turning off Send Connected Line for the extension. That will probably fix your issue, but may omit other display updates that you want.


(Joshua Cadman) #3

Where would I be able to turn off Send Connected Line


#4

In the FreePBX admin GUI, go to Applications -> Extensions, click the edit button for the extension you wish to change. Click the Advanced tab.

For a pjsip extension, set Send Connected Line to No.

For a chan_sip extension, set Send RPID to No.

Click Submit. Click Apply Changes. Test.


(Lorne Gaetz) #5

I would disable connected line / rpid for the trunk.


(christrati) #6

I remember having the same issue and had to change the following settings in the Advanced Settings:

If you set the “Display CallerID on Calling Phone” to No, it will then not show the number you’re dialing out on. I had an issue with S400s where they only show one line of CID, hence it would only show the outgoing CID they were dialing out. Once I set it to No and set the next setting “Display Dialed Number on Calling Phone” to Yes, it would then show the outgoing number they dialed.

Hope this helps.

Chris


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.