Change from email for voicemails

Our email provider has started to block the email notifications coming from our freepbx server because they are not coming from a valid domain.

I changed the From Address field in the notifications settings section of the system admin module to [email protected], and I am now able to received the notification emails again.

I changed serveremail field to [email protected] in the voicemail admin module, but the emails are still being sent from [email protected]

What am I missing to change the from email for the voicemail notifications?

Check in the voicemail.conf file to make sure that this change has actually been made? Since the change have you reloaded or restarted Asterisk? Try that as well.

in /etc/sysconfig/network

If you know how to use an editor to edit the file system do this

vi /etc/sysconfig/network

Then change the hostname to something like pbx.mycompanyABC.com

Then save and type this:

service network restart

That should do it.

@leemason the change was applied in voicemail.conf and a reload was performed, but the change did not take affect.

@fanklin I tried changing my settings in /etc/sysconfig/network and restarted the network service as suggested, but message is still being sent as [email protected], and now my server is trying to connect to my domain controllers to send the message. Also even if this solution had worked it would not allow me to specify the full from address for the voicemail emails, just the domain.

Please note that The fail2ban emails are successfully being sent as [email protected] with the only change being made in the notifications section of the systemadmin module of the freepbx gui.

Here is how I got it to work:

  1. in freepbx gui set serveremail in voicemail admin > settings to [email protected]
  2. edited /etc/postfix/main.cf
    a. uncommented mydomain paramater in INTERNET HOST AND DOMAIN NAMES section
    b. set mydomain = mydomainname.com
  3. service postfix restart

accounts set to email voicemails as attachments are now receiving emails from [email protected]

Is it a bug that the postfix setting has to be manually changed?

Another would be to set a subdomain at your hoster like I do and make that your hostname. Emails go out as hostname.mydomain.com and my domain recognizes them and passess them, as well, my local ISP passes them. Different ways to skin this cat. good job.

Hi @StaceyB

I am new to this… How do you execute steps 2-3, is this through freepbx gui or through asterisk?

Nate