CHAN_SIP technology listening on Port 5160

Hello everyone

When Am opened the extension like 100, I saw in General :

“This device uses CHAN_SIP technology listening on Port 5160 (UDP - this is a NON STANDARD port)”

Any one can told me whats meaning that?

Or how can i change port of sip from 5160 like ip server 192.168.1.10:5160 to port 5060 like 192.168.1.10:5060 when Am using SIP, And now using PJSIP, because my office infrastructure and all devices worked with port 5060 SIP, Can i change it to goal the compatibility between all devices.

You can control which SIP driver is bound to which port in Settings -> Asterisk SIP Settings:
https://wiki.freepbx.org/display/FPG/Asterisk+SIP+Settings+User+Guide

The “Standard SIP” port is 5060. It is currently being listened to by PJ-SIP (in most modern installations). The Chan-SIP SIP interface is an alternate (older, getting ready to lose support, deprecated, etc.) interface that is available if you want to use it.

  • SIP is the protocol.
  • Chan-SIP is a SIP Channel Driver.PJ-SIP is also a SIP Channel Driver.

The SIP protocol is normally associated and listens on port 5060, but can be set up to listen to literally any port number. There have been many “alternates” through the years. FreePBX settled on 5060 as the primary for the main channel driver and 5160 as the secondary for the alternate channel driver. These are just the defaults; as @lgaetz pointed out, you can set them up to listen on almost any available port anywhere in the range from 1025 to 60000-ish.

As a community, we’ve more or less come to agree that local phones should be connecting and be handled by PJ-SIP. For most ITSPs, it is also the best choice. Chan-SIP should only be used in specific cases now and then only when you can’t get PJ-SIP to work.

If you are using PJ-SIP and port 5060, you are actually in the right space for the technology moving forward. Chan-SIP was a workhorse, but getting to be time to let it go.

Thank you for your replay,
I tried and its worked fine,but now i need to change extension account from 192.168.1.100:5060 by extension 300 to 192.168.1.100 without :5060 because when i write the information about account of extension in softphone like zoiper or 3cx or x-lite, This programs need to write the 192.168.1.100:5060 with port but i need to change something to shortcut ip server without port “5060”, How can i change this?
please advice
Thank you
Capture

Thank you for your replay,
But now i need to change extension account from 192.168.1.100:5060 by extension 300 to 192.168.1.100 without :5060 because when i write the information about account of extension in softphone like zoiper or 3cx or x-lite, This programs need to write the 192.168.1.100:5060 with port but i need to change something to shortcut ip server without port “5060”, How can i change this?
please advice
Thank you
Capture

You have two choices:

  1. Change the host entry so that it says 192.168.62.154:5160 (assuming your PBX’s IP address is 192.168.62.154 - seems like a very random number).

  2. Change the extension so that it’s a PJ-SIP extension (instead of Chan-SIP). For these softphones, you should be using PJ-SIP extensions anyway.

Also, you only need to post once per forum.

My problem when i need to clear the port of PBX’s ip address “5160 or 5060”
I need to write only :

  • Domain: 192.168.62.154
  • username: 200
  • password: x.x.x.x.x

And you can see photo below :


So when you see in photo step 1: how can write the ip of address without port like 192.168.62.154,
After applying to save the change, I saw registering by step 2 in photo,
How can to doing that.

Use PJ-SIP. That will make this work. The assumed port for SIP in these programs is 5060, so you just need to set up the extensions as PJ-SIP extensions.

In other words - don’t use Chan-SIP unless you have to, and if you are going to use Chan-SIP, include the port number in the IP Address (x.x.x.x:5160).

If you MUST use Chan-SIP and need it to be on port 5060, you can set that up in the Advanced SIP Settings screen. Set PJ-SIP to 5160 and Chan-SIP to 5060 and you are once again in business.

1 Like

Just put 192.168.62.154 into the domain as you already have it. Most VoIP clients tend to use port 5060 as default SIP port unless you change it to another port with the port listed after the ip address. (i.e. :5060).

After applied and check, it’s worked as well without write port in “Domain” but I’m had problem, If i call from zoiper to ip phone (Grandstream GXP2160), I can hear,ok
But if i call from ip phone (Grandstream GXP2160) to zoiper i can’t hear anything, it’s codec problems?
How can i resolve that.

Yes, I have tried to change from chan-sip to pj sip and worked,but I’m had problem, If i call from zoiper to ip phone (Grandstream GXP2160), I can hear,ok
But if i call from ip phone (Grandstream GXP2160) to zoiper i can’t hear anything, it’s codec problems?

Normally, when there’s a codec mismatch, the call will ring, connect, and immediately terminate.

Chances are that your NAT settings on one leg of one of these calls (I’m going to guess the Zoiper to PBX) is not set up correctly.

When you call from one phone to another, you aren’t actually calling one phone to another. You are calling from the phone to the PBX and the PBX is talking to the other end of the conversation. Asterisk is a Back to Back User Agent, which means all calls are actually going to and from the PBX.

Yes, I’m solved the problem before 2 days ago, the problem was in codec,
Now the extension between zoiper and IP PHONE now working.
Thank you for your help

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.