Chan_sip bind port issue

Hi, Guys

I’ve an issue with chan_sip port.
My SIP TRUNK Stops working suddenly sometimes within a week sometimes within a month.
In the logs it says: Trunk Registration Timed Out
When I change the specific port as is on the photo on any different number sip trunk works.
My Freepbx is in DMZ and there is no other device that uses 5000-6000 range port.
This happens always when the router is restarted. But the router doesnt block any port on my freebpx.
Could you guys please help me what is wrong? Thanks.

DMZ does not always preserve the source port number. This can result in a ‘poisoned’ NAT association being kept alive by aggressive registration retries.

Turn off DMZ and instead forward the UDP port range for RTP (default 10000 to 20000) and the Bind Port (your value 5185) to the PBX. If you require access to other services from the outside (pjsip, provisioning, UCP, etc.), forward those ports also.

If this doesn’t help, in Asterisk SIP Setting, chan_sip tab, try changing Registration Timeout to e.g. 600 (longer than the UDP timeout in your router), which should delay registration retries enough to allow the bad NAT association to clear. If you are using qualify, also set a long qualify frequency.

If you still have trouble, please post details including:
FreePBX and Asterisk versions? If recent, why are you not using pjsip for the trunk?
Trunking provider?
Router make/model? Any special settings besides port forwarding, e.g. SIP ALG?


Changed to pjsip seems to work. Thanks!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.