CFWD to external with hidden caller not work (mute)

On a fresh install FreePBX
Using SIP channel settings

Got some problem with call forward to external number.
CFWD works good except when caller call with an hidden phone number, in this case we got no sound!

Did someone got this and sort this problem ?

Thank you for your help

That doesn’t sound right. I’ll bet you actually have problems with this with a lot more than call forwarding.

Tell us how you are setting up the trunks and how you have CFWD enabled - this sounds like a problem with your firewall (possibly) not being able to redirect traffic in and then back out to the same source (if you are using the same VOIP provider for both connections).

I set up a special connection through my “alternate” provider that connects my employee cell phone numbers so that the calls that come in on the primary are always routed out through the secondary to specifically avoid what you are describing.

Thank you for your answer cynjut!

Server is inside our network not on DMZ
Firewall route all UDP traffic from 10000 to 20000 to our FreePbx server

Trunk is a SIP type, default setting, only options are:

CFWD is enabled directly from phone (snom 710) to external mobile phones.

Ship channel driver use is chan_sip
on Sip parameter i set external ip, local networks
in advanced sip parameters is use : NAT
and progressinband=yes as extra sip setting

I’m not as familiar with Snom as other folks, so one of them might jump in, but there are sometimes two ways to set up Call Forwarding. One is through the server, and one is through the phone. Have you tried using the System’s CFW instead of the phone’s? With a NAT network and phones behind the firewall, it could be a simple problem with the RTP redirection not making its way to the destination.

Your SIP connection details all look fine, so it probably isn’t something specific to your connection.

I’ve also had problems with “reflecting” a call out through the same SIP trunk it came in on. This causes one-way audio because the firewall can get confused about how to get the traffic from the outside interface to the inside interface. I set up a separate outbound route and trunk (on a different provider) so that calls to my client cell phones can be redirected properly.

One-way audio is almost always a firewall problem. I see you’re using Chan-SIP, but there have been sporadic problems with PJ-SIP in configurations like this. In spite of that, the RTP traffic is getting lost somewhere along the line. A SIP Debug listing might help you figure out what the problem is. Wireshark (scanning the phone) might also give you some insight into the problem.