Certman update breaks my certman_cas table

I’m running 14.0.1beta1 with latest modules on Stable build track.

I just went to apply the new Certificate Manager (certman) update and it broke the “certman_cas” table due to key length.

I initially attempted via web UI, then attempted via terminal:

When I attempt a rollback to prior releases I get the same error. When I fully un-install and re-install I get the same error: ‘ALTER TABLE certman_cas CHANGE basename basename VARCHAR(255) NOT NULL UNIQUE’: SQLSTATE[42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 767 bytes

Thanks. Will fix tomorrow. It’s a problem with utf8 limits. Affects 14 only.

1 Like

Fixed in

@tm1000 thank you that worked great – just one minor issue…

Once I applied the update it did take and worked fine, but a new error exists that did not previously:

Module: “FreePBX Framework”, File: “/var/www/html/admin/libraries/Composer/vendor/bin/doctrine-dbal missing”

I figured a fresh download / install of the framework module and/or reboot would work this out but it did not.