Certificate Manager error -

I was trying to create a Let’s Encrypt certificate. I have the latest updates, which mention the firewall being configured automatically. I have no other external firewalls.

I am getting the following message.

There was an error updating the certificate: openssl_csr_new(): dn: add_entry_by_NID 16 -> (failed)
 New Certificate 

Where to look for more details?

Tried to generate a new self signed certificate.

Error Generating Certificate: Signature ok subject=/CN=localhost.localdomain/O=localhost.localdomain Getting CA Private Key unable to load CA Private Key 140119661279048:error:06065064:digital envelope routines:EVP_DecryptFinal_ex:bad decrypt:evp_enc.c:596: 140119661279048:error:0906A065:PEM routines:PEM_do_header:bad decrypt:pem_lib.c:483:

Would really appreciate some tips on where to find more information. Is there a log somewhere for the Let’s Encrypt that I could find more details on the error?

Well - hate to answer my own question. But I played with this a bit longer, focusing on the Let’s Encrypt part.

First, did manage to get it to install the certificate. I had to fill in the text for the state, I assumed the gray text (which was correct) would be default. I typed in the state and it worked.

I will delete everything and try again and if same, will file a bug.

Also, I used system admin module to update the certificate. It hung on “installing” for a long time, but appeared to work. With the exception of requiring a “service httpd restart”.

I’ll spend some more time on this over the next few days.

Fixed in certman v13.0.24

1 Like