Certificate manager AND DTLS bug

Hi, I’m using FreePBX 13.0.1beta3.45 and I try to test WEBrtc functionality.
I’m install Certificate Manager 13.0.2 and gen certificates. Then I’m configure DTLS settings under Extension config and when try to apply the configuration, I see this strange error

Reload failed because retrieve_conf encountered an error: 255

exit: 255
Unable to continue. Unable to locate the FreePBX BMO Class 'Pjsip’A required module might be disabled or uninstalled. Recommended steps (run from the CLI): 1) fwconsole ma install pjsip 2) fwconsole ma enable pjsip in /var/www/html/admin/libraries/BMO/Self_Helper.class.php on line 216
1 error(s) occurred, you should view the notification log on the dashboard or main screen to check for more details.

No problem with pjsip module as far as i see. This bug reproduce by enable the “DTLS Enable ON” under the extension config.

I think this is a bug.
Can somebody help me with this?

Best regards

I’m sorry, I can’t duplicate this one.

What I -can- do, however, is see that chrome works happily for a bit, but then the calls drops out with “ast_srtp_unprotect: SRTP unprotect failed with: authentication failure 10”

Ок, today I updated core to 13.0.1beta3.45 but problem still not solved for me.

I dont know what is this happen, but if I provide you a remote access to server, could you trace the problem ?

1)I installed Freebpx 13 on my test notebook according this manual http://wiki.freepbx.org/display/HTGS/Installing+FreePBX+13+on+Ubuntu+Server+14.04.2+LTS
2) install CertManager
3) Generate Certificate
4) Create pjsip extension 101 with default settings
5) click Save->Apply (everything ok)
6) change DTLS enabled -> ON
7) click Save->Apply (Failure with error I described above)

What I’m doing wrong ?
Thanks in advance.

Can you confirm this problem ?

can somebody reproduce this problem?

Thanks. Problem solved in Certman 13.0.4