Certain extension numbers can't be dialled


(Singer Instruments) #1

Hi all

I’d better start with a bit of background. I work for a small company and we have a Foncordiax box running FreePBX, which all our incoming calls are routed to and we have about 35-40 phones (mostly Polycom IP handsets) with internal extension numbers.

The person managing all the IT systems left suddenly a couple of years ago and myself and a colleague have been trying to figure out all the systems since, as we were the best qualified employees with some previous IT experience (both of us are employed primarily to do other roles). The phone system was/is the one system we’ve struggled with the most as we were completely unfamiliar with it, and other companies won’t touch the current system as they haven’t provided it. They have only offered us a replacement system (at considerable cost). As we are a small company, we don’t have enough IT requirements to hire someone full time, so have to make do (currently) with the situation as it is.

It seems we have a very old version of FreePBX (says it’s 2.8.1.5), so initially found it quite difficult to manage due to lack of online resources for this version. In playing with the system (and making some mistakes along the way), I’ve got to a point where I’m able to administrate it enough to keep it ticking over, until we can budget for a new system (hopefully next year).

So on to the problem… I’ve recently amended our user extension numbers, so they’re more logical. They follow the same format as before (they’re all 3 digits, eg. 101, 304, 607), but are now organised by departments (so everyone in sales would be 1xx for example) which makes far more sense and is easier to update in the future.

I have a few numbers within the 7xx group, but it’s not possible to dial or transfer calls to them under certain circumstances. If you dial a number, say 701, initially with the handset down, it dials fine and rings the phone on extension 701. However, if you pick up the handset first (hearing a dial tone) and dial the number, only the 7 gets recognised and then it says “I’m sorry, that number is not valid. Please try your call again later”. This wouldn’t be a problem if it was just internal calls being made as we could do it with the receiver down, but sometimes it’s necessary to transfer a call to one of the 7xx group and when transferring, it does the same as with the handset lifted. Thus, it’s impossible to transfer a call to one of those number.

I’ve checked through all the settings I know and I can’t find any reason it’s doing this. It only seems to be numbers starting with 7. I’ve tried searching for the same problem but have been unable to find this anywhere else, so thought I would see if anyone could help! Of course the easy way would be to just ignore 7xx numbers and I’ll do this if I have to, but that’s not ideal.

Any suggestions would be very much appreciated, although please remember I am not an expert in this system so I may need a little more help than others.


(Nate) #2

Hi,

Have you tried doing a test call and then examining the call in /var/log/asterisk/full to see what Asterisk is hearing when you dial with the handset lifted vs down?

That might provide some clues.

EDIT: Also requisite but probably unhelpful urge to upgrade to a supported version added for the record :wink: If you have a spare PC lying around and an Internet connection you can download an ISO of the FreePBX distro and build a replacement for nothing but time.


(Lorne Gaetz) #3

This is indicative of a phone misconfig. The dialplan (alternatively called digit map) in the phone needs work.