CDR reports were not working just Upgraded the system to but still no luck

CDR reports are not working just upgraded the to the latest version but still the reports and recordings not working.

Can someone guide me on how get CDR working with Freepbx

Thanks in advance for all your help.

I don’t know why it’s not working for you, but if you can’t get it working you could try the beta version of the new reports module that will likely be in 2.10:

Beta testers wanted for new CDR report tool (UPDATED)

i installed the CDR viewer beta version, installed perfectly without any errors but no still results in the viewer.

may be some database connection problem?


Call Detail Record (CDR) settings

Logging: Enabled
Mode: Simple
Log unanswered calls: No

  • Registered Backends


how can i test if the database is connected?

Your database isn’t connected, should look like this:

localhost*CLI> cdr mysql status
Connected to asteriskcdrdb on socket file default using table cdr for 39 days, 19 hours, 8 minutes, 15 seconds.
  Wrote 74006 records since last restart.

localhost*CLI> cdr mysql status
No such command ‘cdr mysql status’ (type ‘core show help cdr mysql’ for other possible commands)

What shall i do now?

What version of Asterisk do you have?
Is your setup done by a distro or is it hand built?

Asterisk (Ver.
Setup done by Distro bur than i did some upgrades

never got the CDR reports working.

OK, when you said “I did some upgrades” I assume that you upgraded Asterisk. You need to install Asterisk-Addons for the version of your installed Asterisk.

Download and install asterisk-addons- from

i upgraded the Asterisk again yesterday and now its Asterisk (Ver.
But still no data in CDR reports
Do i need to install the Addons for Asterisk (Ver.