CDR Reports duplicated

I’m having an issue where all of my CDR report entries are duplicated.

I have the ‘Asterisk Logfiles’ module installed, but disabled. I’ve checked that logger_logfiles_custom.conf is empty:

[[email protected] ~]# cat /etc/asterisk/logger_logfiles_custom.conf
[[email protected] ~]#

Any ideas on what may be causing this?

FYI, this was due to the fact that I had both /etc/asterisk/cdr_mysql.conf and /etc/asterisk/cdr_adaptive_odbc.conf configured.

Worked for me also, thanks. Why is this set up like this in the distro?

I figured out that when I switched to just using cdr_mysql.conf that the recordings did not populate in the cdr report, so I instead resoted cdr_adaptive_odbc.conf and removed the contents of cdr_mysql.conf and now I only get one cdr entry per call and I get the recording populated as well.

Any problem with being configured this way?

I edited your post above to prevent users from using this as a solution.

If you go through the upgrades this is corrected in updates.

for a real time fix
in /etc/asterisk/modules.conf add noload =>
in the asterisk cli: module unload

The FreePBX distro uses ODBC

I read many guides on Duplicate CDR records, but this one worked, and I was able to resolve the situation during the middle of the day without restarting asterisk! Thanks !

PS: asterisk -rx “module unload”

Is what fixed it for me during the day, then change the modules.conf for “long term” fix.