CDR reports destination field

Asterisk variables are not working in reports
it is blank when I’m using _2XX
but according to desc they should
CDR Reports 15.0.24.3


but in fact calls are there

Right because the CDR report is looking in a database which has no relation to Asterisk pattern matching.


here you can see when you hover on ?
that “ASTERISK pattern” are acceptable

Well then it’s doing some sort of conversion somewhere in the code because you can’t query that in the database. Have you tried checking the radio button next to Destination to see if that helps.

yes i tried

does it work on your side for example?

Nope and I even went back to an old v14 box too. Didn’t work there either.

Huh, yea I never realized that the tool tip was instructing that. I tried on one of our systems and it doesn’t work for me either. Wonder if that functionality was present at some point but no longer and that tool tip never got updated?

yes i was able to use it in FreePBX 12 I think

The function still exists in the code, I would need to double check if it is being called or not.

thanks let me know