CDR Report not working

I have installed freePBX 2.8 on asterisk 1.6 in two different boxes, and after installing and updating everything in sight for the last 2 days (includding asterisk addons16) still cant get any report aka log of calls on my mysql. I’ve seen many people with similar errors going back 7 or 8 months ago with different results. Any help guys? (limitted knowledge when compiling sources). (thanks)

Hello

I have done that yum update asterisk16* and the cdr began to work, but the FOP is not working now

Checking some posts here I ran into this pretty neat suggestion: run an update like this to solve that issue: yum update asteriisk16* After this, restarted asterisk … and voila !! it works!! thanks guys for the inputs.

Asterisk addons is not loaded that is why you don’t have the command.

[cdoe]

skyPBXhomeCLI> cdr mysql status
Connected to [email protected] using table cdr for 17 days, 0 hours, 6 minutes, 7 seconds.
Wrote 533 records since last restart.
skyPBXhome
CLI>
skyPBXhomeCLI> module show like mysql
Module Description Use Count
app_addon_sql_mysql.so Simple Mysql Interface 0
res_config_mysql.so MySQL RealTime Configuration Driver 0
cdr_addon_mysql.so MySQL CDR Backend 0
3 modules loaded
skyPBXhome
CLI>

[/code]

You’re right, that’s exactly the problem as it seems, the modules are not being loaded. This is the result I get from the: module show like msql: Module Description Use Count
0 modules loaded
I tried searching ways of loading those addons modules but no luck. I followed this link instructions, but still nothing. http://www.spiration.co.uk/post/1327/asterisk-addons%20setting%20up%20mysql%20cdr%20for%20Asterisk

-Thanks,

Well, actually I’m using webmin and I can see that asterisk and asteriskcdrdb both have the user freepbx with all permissions available. The command cdr mysql status doesnt run on the cli.

I’m using freepbx 2.7 and I have the same error, I’m using AsteriskNOW 1.7, always when I make yum install asterisk16-addons it begins to work, but this time it doesn’t work.

I’ve tried:
localhost*CLI> cdr mysql status
No such command ‘cdr mysql status’ (type ‘core show help cdr mysql’ for other possible commands)

localhostCLI> cdr show status
localhost
CLI>
Call Detail Record (CDR) settings

Logging: Enabled
Mode: Simple
Log unanswered calls: No

  • Registered Backends

    (none)

I should try updating the mysql package of centos? I have more than 100 users maybe that can cause the error?

What is the output of the command “cdr mysql status” ?

Did you grant permissions for the cdr database to Asterisk?

I have the same problem!

CLI> module show like mysql
Module Description Use Count
0 modules loaded

asterisk16 * yum update did not work.
command returns:
No Match for argument: asterisk16 *
In asterisk16 package * available.
No Packages marked for Update

I have downloaded lastest versions of addons try it