CDR is not working in Freepbx 12 Ubuntu

I installed FreePBX 12 on Ubuntu 14.04. When I try to run the CDR report, nothing is reported.

I ran CLI: cdr show status and got the following:
Call Detail Record (CDR) settings

Logging: Enabled
Mode: Simple
Log unanswered calls: No
Log congestion: No

  • Registered Backends

    Adaptive ODBC

I ran CLI: module show like cdr and got the following:
Module Description Use Count Status Tell Asterisk to not maintain a CDR for 0 Running Fork The CDR into 2 separate entities 0 Running Adaptive ODBC CDR backend 0 Running Comma Separated Values CDR Backend 0 Running Customizable Comma Separated Values CDR 0 Running Asterisk Manager Interface CDR Backend 0 Not Running ODBC CDR Backend 0 Not Running SQLite3 Custom CDR Module 0 Not Running Customizable syslog CDR Backend 0 Not Running Call Detail Record (CDR) dialplan functi 0 Running

First check for an errors while loading the module in asterisk CLI first

module unload
module load

these files all need to be properly setup:-


I got the following after running module load
WARNING[8665]: cdr_adaptive_odbc.c:112 load_config: Unable to load cdr_adaptive_odbc.conf. No adaptive ODBC CDRs.