Can't upgrade freepbx from 15 to 16 because of php package not located anywhere

When I run fwconsole versionupgrade --check it looks good, the coast is clear. When I run fwconsole versionupgrade --upgrade , I get the following. I’ve googled endlessly for sng-php74 and I can’t figure out how to resolve this error anywhere. Has anyone had this experience going from 15 to 16?

Tue Nov  7 13:32:44 CST 2023 Enabling sangoma-release16 repository ....

Loaded plugins: fastestmirror, versionlock

Loading mirror speeds from cached hostfile

No package sng-php74-repository available.

Error: Nothing to do

Tue Nov  7 13:32:46 CST 2023 Failed to install sng-php74-repository package. Exiting upgrade process..

Someone suggested following instructions here however this just redirects to which is generic and useless.

I poked around a little to find this, and was excited!

however, this guide links you to this page which, you guessed it, redirects to this junk page here…

I tried using to fight back against all the dead redirects, but no luck. I am close to giving up. Where can I find sng-php74-repository, or any working instructions on how to do this?

if you can take a backup I would almost always suggest taking that backup and then installing 16 and restoring over the in-place upgrade

ive successfully restored as old as 2.11 systems with only minor tweaks required , 15 to 16 should be seamless for you

I think this is what you are looking for

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.