Can't upgrade 4 modules

Hello Community,

Running FreePBX

restapps, vqplus, zulu & xmpp are throwing the same error when trying to upgrade.

Upgrading zulu…
Starting zulu download…
Processing zulu
Verifying local module download…Verified
Module zulu successfully downloaded
Detected Missing Dependency of: pm2
Found local Dependency of: pm2
Installing Missing Dependency of: pm2
Installing/Updating Required Libraries. This may take a while…The following me ssages are ONLY FOR DEBUGGING. Ignore anything that says ‘WARN’ or is just a war ning
Running installation…
This account is currently not available.

Finished updating libraries!

There was an error installing. Please review the install log. (/var/www/html/adm in/modules/pm2/node/logs/install.log)
The following error(s) occured:

  • Failed to run installation scripts
    Unable to resolve dependencies for module zulu:
    Updating Hooks…Done
    All upgrades done!
    Updating Hooks…Done

tail /var/www/html/admin/modules/pm2/node/logs/install.log

This account is currently not available.

I already tried to remove pm2 and re-install.

Any suggestions much appreciated.


I had the same issue. During the upgrade, the login shell for the “asterisk” user account was changed to /sbin/nologin, preventing that user from inputting commands.

In the CLI as root, enter the following: nano /etc/passwd

Arrow down to the asterisk line, and replace the “/sbin/nologin” with “/bin/bash” (without the quotes). Press Ctrl + X to exit, then Y to save. Try your installation again.

The user’s line should read something like: asterisk:x:499:498::/var/lib/asterisk:/bin/bash