Can't update to FreePBX 13 Alpha

I’ve got a problem after applying the sequence of theese updates:

During appying second initial update I received a fatal error with the framework update.
Here is some screenshots.

This print-out appears about a minute after STAGE 3 begins.

The updates complete to the end, and then it says that error occured while FreePBX 13 update.

Is there any way to fix this? Thanks.

Does anything work?..

Try the script again or try to check online manually.

Believe me, I’ve tried it several times with no changes.
Also tried to manualy uninstall and remove the framework, ucp, sysadmin modules with module_admin and reinstall them. It says reinstall is successful and everything seems to work fine, but the script gives the same error.

And one more thing: fwconsole is not available, when log in there’s a critial error about that.

What version of framework do you have?

Now it is 12.0.69, according to Module Admin.

When you checkonline what are you presented with?

Like it is up to date.

amportal a m
select * from admin where variable = 'version';

The answer is 12.0.69

amportal a m
update admin set value = '13.0.0alpha1' where variable = 'version'


amportal a ma upgrade framework
fwconsole ma updateall

Something went not good.

A little issue

And a great one.

Those are hardly huge errors. Try to install backup again

fwconsole ma upgrade backup


, this is done.

Now you can update voicemail

fwconsole ma update voicemail

I repeated upgradeall, and now everything is working fine and up-to-date!
Thank you, doctor :smiley:

Now it’s something wrong with restapi. Refuses to install.

12.0.1 was installed version.
13.0.2 is presented.

This is the issue:

Do you need restapi?

I’m not sure, but I prefer not to have issues :smile: But if I don’t need it, I trust you.

Another trouble: Misc Apps.
This I need.