FreePBX | Register | Issues | Wiki | Portal | Support

Can't update system msg Whoops \ Exception \ ErrorException


(Neal Garrett) #1

when attempting to update system this morning I get the following error going into update.
Whoops \ Exception \ ErrorException (E_ERROR)
Call to a member function moduleLicenseInformation() on boolean

logged into root and ran yum update
Same issue after running yum update

ran fwconsole ma upgreadeall
Still same error but now says nothing else to update

Rebooted system same error when going into update

Forgot a key part i’m running version PBXact UC 14.0.2.18


(Andrew Nagy) #2

Please paste the error in full


(Neal Garrett) #3

GET Data
display updates
POST Data empty
Files empty
Cookies
lang en_US
searchHide 1
PHPSESSID q0h78gi8lnrroiq84o5cl8lqj1
_ga GA1.1.372269213.1524913014
_gid GA1.1.469111296.1524913014
Session
langdirection ltr
module_name dashboard
module_page index
AMP_user ampuser Object ( [username] => neal [id] => [password:ampuser:private] => f0a9f313029be92e90aa45650d332b096e24980c [extension_high:ampuser:private] => [extension_low:ampuser:private] => [sections:ampuser:private] => Array ( [0] => * ) [mode:ampuser:private] => database [opmode:ampuser:private] => [lang] => [tz] => [dateformat] => [timeformat] => [datetimeformat] => [_lastactivity] => 1524944111 )
Server/Request Data
UNIQUE_ID WuTM73pziHBa0duWXpzI5wAAAAo
SCRIPT_URL /admin/config.php
SCRIPT_URI https://192.168.15.64/admin/config.php
HTACCESS on
HTTPS on
HTTP_HOST 192.168.15.64
HTTP_CONNECTION keep-alive
HTTP_UPGRADE_INSECURE_REQUESTS 1
HTTP_USER_AGENT Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36
HTTP_ACCEPT text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,/;q=0.8
HTTP_DNT 1
HTTP_REFERER https://192.168.15.64/admin/config.php
HTTP_ACCEPT_ENCODING gzip, deflate, br
HTTP_ACCEPT_LANGUAGE en-US,en;q=0.9
HTTP_COOKIE lang=en_US; searchHide=1; PHPSESSID=q0h78gi8lnrroiq84o5cl8lqj1; _ga=GA1.1.372269213.1524913014 ; _gid=GA1.1.469111296.1524913014
PATH /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
SERVER_SIGNATURE
SERVER_SOFTWARE Apache/2.4.6 (Sangoma) OpenSSL/1.0.1e-fips PHP/5.6.35
SERVER_NAME 192.168.15.64
SERVER_ADDR 192.168.15.64
SERVER_PORT 443
REMOTE_ADDR 192.168.15.104
DOCUMENT_ROOT /var/www/html
REQUEST_SCHEME https
CONTEXT_PREFIX
CONTEXT_DOCUMENT_ROOT /var/www/html
SERVER_ADMIN root@sangoma.localhost
SCRIPT_FILENAME /var/www/html/admin/config.php
REMOTE_PORT 61794
GATEWAY_INTERFACE CGI/1.1
SERVER_PROTOCOL HTTP/1.1
REQUEST_METHOD GET
QUERY_STRING display=updates
REQUEST_URI /admin/config.php?display=updates
SCRIPT_NAME /admin/config.php
PHP_SELF /admin/config.php
REQUEST_TIME_FLOAT 1524944111 .409
REQUEST_TIME 1524944111
Environment Variables empty
Registered Handlers
0. Whoops\Handler\PrettyPageHandler


(Andrew Nagy) #4

You failed to post the stack trace of the error. Please take a screen shot of the error


(Neal Garrett) #5


(Andrew Nagy) #6

This error means your system is not a true PBXact system. Please open a ticket up with support.


(Neal Garrett) #7

Hmmm that is interesting it was until the last updates… I also have a UC75 that is on the same version and it has the same issue. The UC75 has not even been deployed to the field yet.

I will open a ticket with support. Thanks


(Neal Garrett) #8

Maybe I will try again tomorrow to open a support ticket i’m getting the following on the Sangoma Portal when I try to go into support>support tickets

This page isn’t working
support.sangoma.com is currently unable to handle this request.
HTTP ERROR 500


(Tony Lewis) #9

Neal

From the CLI update your license with

fwconsole sa u

That should fix it. Seems your license is not updated.


(Neal Garrett) #10

That corrected the issue on both boxes. Is this already a known issue or does this need to be opened a bug something went wrong on the last set of updates that created this issue?

All services didn’t start back up what command do I run to get these going?
Restapps
UCP
Queue
Xmpp
Zulu

Thank you for the help.


(Itzik) #11

fwconsole restart


(Neal Garrett) #12

As far as I can tell i’m good again…

Thanks everyone…


(Tony Lewis) #13

This has been fixed. It was a server side issue change we had made to simplify things for OEM partners which also affected PBXact since under the covers it’s a OEM on FreePBX.


(system) closed #14

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.