Can't update calendar: "MySQL server has gone away"

When trying to use “Update from Source” button in Calendar, I get the error:

SQLSTATE[HY000]: General error: 2006 MySQL server has gone away
File:/var/www/html/admin/libraries/BMO/DB_Helper.class.php:651

Pretty much the same via cli:
[[email protected] mariadb]# fwconsole calendar --sync --force
Starting Sync…
Syncing Test…
In DB_Helper.class.php line 651:

SQLSTATE[HY000]: General error: 2006 MySQL server has gone away

However, I don’t see anything in /var/log/mariadb/mariadb.log that would indicate that Maria actually terminated or restarted… maybe there’s another log I should be looking at?

FreePBX 15.0.17.34

Thanks!

After much trial and error, I found that simple (small) ICS files worked. I added max_allowed_packet = 128M to my.cnf and that got rid of the “MySQL server has gone away” message, but then created a new “There was an error fetching the events” message. The browser console showed that it was an index issue with dtend. Eventually, I had to switch the Google Calendar to be Public and to show only Free/Busy (not full details) and it worked. It looks to me like Google is formatting the dtend differently for Full/Busy than full details, but I have no idea why and don’t really care for the purposes of FreePBX. :slight_smile: Hopefully, this will be useful to someone in the future. :v:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.