FreePBX | Register | Issues | Wiki | Portal | Support

Can't SSH, and no longer have access to iSymphony


(Travis Farmer) #1

Ok, i re-installed from the official distro (latest ISO download), as i changed the system to a different server, though i changed back when i realized the different server did not have enough memory.
so anyway, long story longer…
after a semi-fresh install (after setting up a few things), i may have somehow botched the configuration somewhere as i no longer have SSH access to the server. i have checked the firewall config, and can’t see where it would be denying access. this computer is listed as trusted.

second problem, iSymphony is installed (and re-installed), but appears to not be running. i have downloaded the RPM from getisymphony.com, but without SSH, i my hands are rather tied.

thanks in advance for any help.

~Travis


(Itzik) #2

You probably got banned by intrusion detection. Log into the PBX, Admin > System Admin > Intrusion Detection, see if your IP is blacklisted.
Or… Try accessing it from a different IP.

If you tell us more, we might be able to guide you how to get things done the right way…

You don’t need that, iSymphony comes with the official distro.

On a side note, I’d suggest FOP2 over iSymphony, iSymphony uses much more resources than FOP2.


(Travis Farmer) #3

no banned IPs in intrusion detection.
from alternate IP location:
ssh: connect to host xxx.xxx.xxx.xxx port 22: Connection refused

Admin -> iSymphony states, at the top:
Failed to contact the iSymphony server.
and i can’t login directly either.

not sure now if the config is botched. i can dial out through a POTS trunk line, as well as receive inbound calls now (forgot to setup the trunk config). though i still can’t SSH, or use iSymphony.
i wanted to SSH in to see what the iSymphony config looked like, so i could see if the FreePBX module was setup correctly.

~Travis


(Tom Ray) #4

And have you rebooted?


(Travis Farmer) #5

… not yet, hang on while i reboot.

~Travis


(Travis Farmer) #6

tried to login directly to the server, and it appears the root password has been compromised… the password i set it to fails, and “SangomaDefaultPassword” fails. i have the server now shutdown, via the hardware power button.
suggestions on how to proceed? should i re-install, again?

~Travis


(Tom Ray) #7

There is no default password for SSH. The “root” password is set by you during the install process. If you forget that password you have to perform the standard “Recover/Reset Root Password” steps for RHEL 7.

Otherwise, yeah you will have to do a fresh install. You’ve lost root access to the box.


(Travis Farmer) #8

Hmm, figures. good thing it is a Sunday.
proceeding with a fresh install.

~Travis


(Travis Farmer) #9

ok, i finished re-installing, all re-configured, SSH works, but iSymphony is still non-functioning. i may look into FOP2, if i find i really need it.

~Travis


(Itzik) #10

What do you see on the Dashboard, is it running?


(Travis Farmer) #11

no, it isn’t even listed in the summary.

~Travis


(Itzik) #12

(Travis Farmer) #13

that seems to have fixed it.
I thank you very much!

~Travis


(system) #14

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.