Can't setup Cisco 7960 Phones

I am quite new to FreePBX and SIP. I started a new position at a company that is running an old version of FreePBX. I am simply just trying to get some extensions and phones setup and am having some trouble. I finally was able to get the end point manager setup and have the phone I am trying to get working on the end point manager list. It’s showing as disconnected. I added the extension and everything looked fine. I can see a SIPXXXXXXXXX.cnf file in the /tftpboot directory for this device, however when plugging it in, all I get is: “Phone unprovisioned.”

I tried the same thing with another phone, and this error was, “tftp file not found” even though I could see it in the /tftpboot directory on the FreePBX. If someone can point me in the right direction I would greatly appreciate it. Eventually I will be installing a the latest version of FreePBX and starting this phone system from the ground up.

FreePBX version:
Asterisk version:


Is your DHCP server setting option 66 or are you manually configuring the tftp for the phone?

BTW, that’s not a very old FreePBX

Yes, the DHCP server setting option 66 is setup. I believe I may have had a bad phone, because I can’t even get into the settings on it when pressing settings while it boots.

The other phone shows a paddle-lock under configuration, and I cannot get I don’t know the unlock code. Read somewhere that **# will unlock it but that won’t work either. It’s hard to say what the deal is since I don’t know if these phones are good or bad. The previous IT staff didn’t leave any notes.

I was assuming it was an older version of FreePBX, because from what I’ve read you can’t upgrade this version to the latest? Am I wrong?

Well I’ve tried reloading firmware on one of the phones, and was successfully able to get it to say “requesting information” then it goes right to “Resetting” and then loops back through that. Any Ideas? Have tried deleting and re-adding from the end point device list in freepbx.

After messing with it for a while I was able to get it to work by editing the SIPDefault.cnf file and changing the top line from: POS3-8-12-00 to POS3-08-2-00 which is the firmware I loaded. I cannot find the download for the firmware it has in there. More importantly, why is this file changing on it’s own after a reboot of FreePBX? Thanks!

You need to make that change from the EPM, FreePBX owns the files.