Cant seem to get incoming calls . any suggestions please

Executing [[email protected]:1] Set (" SIP/five-00000001 ", " __FROM_DID=16306395902 ") in new stack

Executing [[email protected]:2] NoOp (" SIP/five-00000001 ", " Received an unknown call with DID set to 16306395902 ") in new stack

Executing [[email protected]:3] Goto (" SIP/five-00000001 ", " s,a2 ") in new stack

Goto (from-pstn,s,2)

Executing [[email protected]:2] Answer (" SIP/five-00000001 ", “”) in new stack

Executing [[email protected]:3] Log (" SIP/five-00000001 ", " WARNING,Friendly Scanner from 54.67.127.248 ") in new stack

[2019-04-21 15:47:27] WARNING [7240][C-00000001]: Ext. s : 3 @ from-pstn : Friendly Scanner from 54.67.127.248

Executing [[email protected]:4] Wait (" SIP/five-00000001 ", " 2 ") in new stack

Executing [[email protected]:5] Playback (" SIP/five-00000001 ", " ss-noservice ") in new stack

<SIP/five-00000001> Playing ‘ss-noservice.ulaw’ (language ‘en’)

Executing [[email protected]:1] Macro (" SIP/five-00000001 ", " hangupcall, ") in new stack

Executing [[email protected]:1] GotoIf (" SIP/five-00000001 ", " 1?theend ") in new stack

Goto (macro-hangupcall,s,3)

Executing [[email protected]:3] ExecIf (" SIP/five-00000001 ", " 0?Set(CDR(recordingfile)=) ") in new stack

Executing [[email protected]:4] NoOp (" SIP/five-00000001 ", " montior file= ") in new stack

Executing [[email protected]:5] GotoIf (" SIP/five-00000001 ", " 1?skipagi ") in new stack

Goto (macro-hangupcall,s,7)

Executing [[email protected]:7] Hangup (" SIP/five-00000001 ", “”) in new stack

== Spawn extension (macro-hangupcall, s, 7) exited non-zero on ‘SIP/five-00000001’ in macro ‘hangupcall’

== Spawn extension (from-pstn, h, 1) exited non-zero on ‘SIP/five-00000001’

You don’t have an inbound route for 16306395902.

thanks…newbie here
Did i miss that on Voicepulse side or in my freepbx setup? Voicepulse registrar string does not have the number attached in it.
or am I missing a freepbx configuration
thanks in advance

You are (probably) missing an inbound route in FreePBX:
https://wiki.freepbx.org/display/FPG/Inbound+Route+User+Guide

thanks for the direction…I’ll work it!!

for my own education could I get this error if an extension wasn’t configured properly??

You were told. Inbound Route.
You were not told, Extension.

ok yes thanks @sorvani


I’m not seeing much in my inbound call route…? If I change “Allow Anonymous Inbound SIP Calls” = YES . I can dial in and extension rings. But I’m assuming this is not a good practice.
I’ve only got one extension and still not able to call in
Any advice on what I’m missing?
Thanks

Found error in my peer sip setup for trunk
host=myhostname.proxy.voicepulse.com

fixed it and voila…extension rings

I guess details matter

Thanks and please close

In your first post, Voicepulse sent the call from 54.67.127.248 but in a later post, you are registered to 54.175.63.250. If the trunking provider can send calls from multiple addresses, you need to get a list of these addresses from them. With chan_sip, you would need to set up a separate incoming trunk for each address (differing only in the host parameter). Or, use a pjsip trunk instead, where you simply list all the addresses in the Match field.

thanks @Stewart1 will do!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.