Can't see Sangoma Card in DAHDi Config

I’ve installed my Sangoma A500 BRI card into my PBX but its not listed in the above.
I’ve read several other discussions and attempted the sugglestion but to no avail.
lspci
00:00.0 Host bridge: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx DMI Bridge (rev 02)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IR (ICH9R) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA Controller [IDE mode] (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA Controller [IDE mode] (rev 02)
01:00.0 PCI bridge: PLX Technology, Inc. PEX8112 x1 Lane PCI Express-to-PCI Bridge (rev aa)
02:04.0 Network controller: Sangoma Technologies Corp. A200/Remora FXO/FXS Analog AFT card
03:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection
04:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection05:04.0 VGA compatible controller: Matrox Electronics Systems Ltd. MGA G200eW WPCM450 (rev 0a)

I tried:
#depmod -a
Rebooted

wanrouter hwprobe

Wanpipe Hardware Probe Info

1 . AFT-A500-SH : SLOT=4 : BUS=2 : IRQ=11 : PORT=1 : HWEC=64 : V=35
2 . AFT-A500-SH : SLOT=4 : BUS=2 : IRQ=11 : PORT=2 : HWEC=64 : V=35

Sangoma Card Count: A500=1

PBX Firmware: 5.211.65-12
PBX Service Pack: 1.0.0.0
Any help would be greatly appreciated. Thanks

Have you gone under the sangoma tab in Dahdi Config module and set it to be in DAHDI mode?

Tried that, set the “Run Wanpipe In DAHDI/DIGIUM Mode:” to yes and the “T1 mode” to E1

Rebooted as requested but card still not listed.

Have checked the “Run Wanpipe In DAHDI/DIGIUM Mode:” setting after reboot and this now says “No”

Still no joy with this, its driving me nuts!!!

Sounds like you are using an outdated DAHDI module. There was a bug that was fixed for this already. Make sure you are using the latest DAHDI module in FreePBX.

Thanks Tony, I’ve already tried that, the module is already up to date (2.11.42).

The FreePBX DAHDi Config (dahdiconfig) module is actually 2.11.42 but it was updated nine days ago to 2.11.43 even if, AFAIK, it was not pushed out as a generally available update yet (and, just to be clear: I don’t really know if that 2.11.43 will rule out your issue as it appears to be related to Fix channel range for Analog T1 and add echocan info while the current 2.11.42 was released to address the FREEPBX-7437 Fix sangoma module bug as per dahdiconfig’s module.xml changelog).

@tm1000 any ideas as my testing showed it was fixed.

It’s fixed in 2.11.42. You don’t need to reboot the system if you want to see if the selection is saving just save it and refresh the page and let us know. If it’s not saving then run:

amportal a dbug

and attempt to save. Post the errors here.

Tried the above:

    ]# amportal a dbug

Fetching FreePBX settings with gen_amp_conf.php..

trying to run as user asterisk:

[FPBXDBUGDISABLE] changed from previous value: [1] to new value: [0]

==> /var/log/asterisk/freepbx_dbug <==

==> /var/log/httpd/error_log <==
[Sun Jun 15 22:05:43 2014] [error] [client 69.174.245.163] File does not exist:                 /var/www/html/phpmyadmin
[Sun Jun 15 22:05:43 2014] [error] [client 69.174.245.163] File does not exist:                 /var/www/html/pma
[Sun Jun 15 22:05:44 2014] [error] [client 69.174.245.163] File does not exist:                 /var/www/html/myadmin
[Sun Jun 15 22:05:44 2014] [error] [client 69.174.245.163] File does not exist:                 /var/www/html/MyAdmin
[Mon Jun 16 04:26:38 2014] [error] [client 80.82.78.112] client sent HTTP/1.1 re                quest without hostname (see RFC2616 section 14.23): /xmlrpc.php
[Mon Jun 16 11:02:14 2014] [error] [client 115.254.9.30] client sent HTTP/1.1 re                quest without hostname (see RFC2616 section 14.23): /webdav/
/bin/mkdir: cannot create directory `/tftpboot/images': File exists
/bin/mkdir: cannot create directory `/tftpboot/images/originals': File exists
/bin/mkdir: cannot create directory `/tftpboot/images/formatted': File exists
/bin/mkdir: cannot create directory `/tftpboot/firmwaredownloads': File exists

# wanrouter hwprobe

Wanpipe Hardware Probe Info

1 . AFT-A500-SH : SLOT=4 : BUS=2 : IRQ=16 : PORT=1 : HWEC=64 : V=35
2 . AFT-A500-SH : SLOT=4 : BUS=2 : IRQ=16 : PORT=2 : HWEC=64 : V=35

Sangoma Card Count: A500=1

Did the setting stick or not. Your views aren’t telling us that.

Sorry, mad moment. Yes the settings did save but I still couldn’t see the card. However on logging off and logging back in I can now see the card. In short it has worked, thank you.

It would appear that you need to execute the “amportal a dbug” command, save the setttings and then logout and back in.

Thanks again.

You don’t need to execute “amportal a dbug” that is only for debugging and has no purpose for saving settings.

Ok, I really don’t get it then! The card just appeared on its own.

Now the card shows and I was able edit settings to start with.

Now I can’t edit anything none of the links in the DAHDI module work, I’ve even upgraded the module to 2.11.45

None of the links under “settings” or the “edit” link under actions work now.

Help us help you. You can bring up the JavaScript console in your browser and it will show you errors

Furthermore you probably have a cage problem or you didn’t hit apply config. Either of those will cause issues

Thank you for your continued help with this.

Ok, I definitely did the “apply config”

The Java console displays when I click any of the links on the DAHDI config page as stated above:

Uncaught SyntaxError: Unexpected token ; nn.nnn.nn.nn/admin/config.php?display=dahdi:1522

Would you mind explaining what a “cage problem” is?

Ok, fixed it now, uninstalled the the DAHDI module and re-installed.

1 Like

Maybe an issue with previous (javassh 2.11.0.0 -> 2.11.1) Java SSH console module version?

Completely unrelated. Java is NOT the same thing as jaavascript, the user accidentally posted “java console” when they meant “javascript”