Can't ring mobile phones inside ring group

I have inserted complete mobile phone numbers as well as virtual extensions with FM to a mobile numbers into a ring group.
When I call group mobile don’t ring.
(They ring when called directly or via the virtual extensions).

Where am I wrong ?

Have you put # after each mobile number?

Sure, direct call to virtual extension with FMFM enabled, ends in mobile phone to ring
The same virtual extension doesn’t ring if put inside a ring group.

This is what is happening:

– Goto (from-internal,LC-253,6)
– Executing [[email protected]:6] Dial(“Local/[email protected];2”, “VIRTUAL/253,40,HhTtrM(auto-confirm^282)b(func-apply-sipheaders^s^1)”) in new stack
[2023-01-27 08:09:28] WARNING[14519][C-000003dc]: channel.c:6337 request_channel: No channel type registered for ‘VIRTUAL’
[2023-01-27 08:09:28] NOTICE[14519][C-000003dc]: app_dial.c:2687 dial_exec_full: Unable to create channel of type ‘VIRTUAL’ (cause 66 - Channel not implemented)
== Everyone is busy/congested at this time (1:0/0/1)
– Auto fallthrough, channel ‘Local/[email protected];2’ status is ‘CHANUNAVAIL’
– Local/[email protected];1 is circuit-busy
== Everyone is busy/congested at this time (1:0/1/0)

Ok, I’m not sure then. I think your SIP trunk provider might be rejecting the outbound request. Check you’re presenting your CID in the correct e164 format.

There is no SIP provider involved here. The OP is trying to use a VIRTUAL provider, but Asterisk has no channel driver for this (and I’d be surprised if one existed). I’m not sure how FreePBX’s GUI would even allow you to configure this.

1 Like

shouldn’t they use misc destination instead of virtual extension if they are just routing calls to an outside number?

I think maybe there is an understanding so let me try.

For external numbers inside ring groups to be dialed a # needs to be added to the end of the number (ie. 15345559999#).

Make sure you are not missing the # at the end of the number inside the ring group.

Calls to outside mobile phone works fine:

I created a Vitual Extension no. 555 with FollowMe FindMe enabled and FollowMe List including mobile phone no. ending with #

If from any pbx extension I call 555 , an outgoing call is placed and the mobile phone rings, all OK.

Now I put ext no 555 inside a ring group, when I call this ring group number it doesn’t work , call doesn’t take place and previous trace is the result.

Please confirm that you put 555# in the ring group entry. Also confirm that it fails even when you dial the ring group number from an extension on the PBX (that’s not part of the ring group).

1 Like

Well, putting 555# on the “extension list” of ring group works !

I just don’t see why this has to be done (as 555 is already an extension , despite it’s virtual), but it’s clearly suggested on “extension list” hint :slight_smile:

Extensions without a ‘#’ will not ring a user’s Follow-Me. To dial Follow-Me, Queues and other numbers that are not extensions, put a ‘#’ at the end.

When creating a ring group, it would often be undesirable for calls to follow the FMFM for each of the entries, so it’s an option that is disabled by default. It also allows some entries in the list to use the FMFM without forcing it for all.

Do you otherwise have a need for the virtual extension? If not, you can just input the mobile number directly in the extension list with a # suffix.

There’s always a reason :slight_smile:
Thanks for explaining, in my case virtual extensions are already done, also non problem in putting mobilenumer + #

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.