Cant register on port 5160

Not sure if this is an asterisk or what. New VM created from distro downloaded from, by default it’s set up with pjsip on port 5160. Chan SIP is disabled but I can only get phones to register on 5060.

If I put 5060 into the phone manually it will register but the PBX shows that it’s registered on 5160

Restarting asterisk and rebooting the machine does not change anything, there has to be a setting somewhere I’m missing. These are Yealink phones

Any suggestions?

PBX Version:

PBX Distro:

Asterisk Version:

You want to look inside Settings → Asterisk SIP settings and the the respective tabs for the different protocols.

Chan_SIP listens on 5160 UDP by default and chan_pjsip listens on 5060 UDP by default. You want to use PJSIP going forward if this is a new setup.

PJSIP is using 5160 and chan_sip is disabled.

Honestly, not sure how you are getting that configuration from a clean install.

Is there a NAT between the PBX and the phones? Are you port forwarding through that NAT from port 5060 to 5160?

I ended up rebooting one more time and then the phones that had been using 5060 to register went offline and everything now seems to work on 5160. No idea what caused this but like the old Nintendo, apparently smacking it and restarting it a few times sometimes fixes the issue. I guess this is resolved now.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.