Can't register/install DPMA in GUI or CLI

I have tried registering DMPA Module in the FreePBX GUI. I went through the registration steps several times and have received a registration number from Digium but the registration never completes, although it says it does.

I spoke with Digium about it and they seem to think it’s an Asterisk or FreePBX issue. I tried installing it with the CLI using this guide

https://wiki.asterisk.org/wiki/display/DIGIUM/DPMA+Installation

But couldn’t get the module to load. I received this error in my log:

Module load res_digium_phone.so 
Unable to load module res_digium_phone.so
Command 'Module load res_digium_phone.so ' failed.
[2015-02-23 15:30:24] WARNING[26005]: loader.c:439 load_dynamic_module: Error loading module 'res_digium_phone.so': /usr/lib64/asterisk/modules/res_digium_phone.so: undefined symbol: _ast_mem_backtrace_buffer
[2015-02-23 15:30:24] WARNING[26005]: loader.c:918 load_resource: Module 'res_digium_phone.so' could not be loaded.

Any idea how to correct this and get it loaded?

What version of Asterisk do you have installed, and what version of DPMA are you attempting to load into Asterisk?

Asterisk version 11 and I’m trying to load DPMA for version 11

Downloading

http://downloads.digium.com/pub/telephony/res_digium_phone/asterisk-11.0/x86-64/res_digium_phone-11.0_2.1.1-x86_64.tar.gz

Asterisk info

[[email protected] ~]# asterisk -r
Asterisk 11.16.0, Copyright (C) 1999 - 2013 Digium, Inc. and others.

Also, apologies, what distro are you running? And, what’s the uname output?

[[email protected] ~]# uname
Linux

FreePBX Distro 12.0.38

Downloading the file from the internet isn’t going to work as the shared objects don’t match from compile time. Regardless, this is provided in the distro. Remove the file you downloaded and run:

yum install asterisk11-res_digium_phone

or

yum install asterisk13-res_digium_phone

That did it! Thanks tm1000!