Can't register FreePBX with Xinix

Hi, I’m currently in the middle of transitioning my VOIP provider from Sipgate to Xinix.

The company itself has provided me with a Grandstream HT701 ATA and I already have a HT812, both of these are able to register just fine.

However on FreePBX I’m unable to register, with errors like:
No response received from ‘sip:(username)@(domain)’ on registration attempt to ‘sip:(username)@(Domain):5060’, retrying in ‘60’

The Details I have been provided are:
Domain/Proxy: (domain)
Outbound Proxy: sip(dot)sipdesk(dot)net
Username: (username)
Password: (password)

In the PJSIP settings, I have tried different settings including:
username/authusername: (username)
domain: (domain)
server port: 5060 (taken from grandstream)
outbound proxy: sip:sip(dot)sipdesk(dot)net:5060;lr

The outbound proxy was taken from the syslog dump of the Grandstream.

Any suggestions on what I can try next?

Try:

Username: (username)
Secret: (password)
Authentication: Outbound
Registration: Send
SIP Server: (domain)
Outbound Proxy: sip:sip.sipdesk.net\;lr\;hide
From Domain: (domain)
From User: (username)

Leave everything else at defaults.

no luck unfortunately, still no response:
No response received from ‘sip:(domain)’ on registration attempt to ‘sip:(username)@(domain)’, retrying in ‘60’

I’m puzzled. Just for laughs, I set up a fake Xinix trunk with Username: 1234, Secret: 4321, SIP Server: example.com
and got (as expected):
[2023-11-07 06:34:40] WARNING[12260] res_pjsip_outbound_registration.c: 403 Forbidden fatal response received from 'sip:example.com' on registration attempt to 'sip:[email protected]', retrying in '30' seconds

So, possibly a network or DNS issue; confirm that you can ping sip.sipdesk.net from the PBX.

If that’s ok, recheck that Outbound Proxy is correctly set (note two occurences of backslash semicolon).

If no luck, at the Asterisk command prompt type
pjsip set logger on
wait for a failed registration attempt, and post the REGISTER request (including the line showing where it was sent).

I just checked and from an ssh login I was able to ping the server.

Here’s a copy/paste of the outbound proxy:
sip:sip(dot)sipdesk(dot)net;lr;hide

As an extra precaution I also tried rebooting the install, but no luck.

Here’s the log:

Here's the log:
<--- Transmitting SIP request (421 bytes) to UDP:145.239.255.24:5060 --->
OPTIONS sip:200f@(domain) SIP/2.0
Via: SIP/2.0/UDP (my IP):5060;rport;branch=(redacted)
From: <sip:200f@(domain)>;tag=(redacted)
To: <sip:200f@(domain)>
Contact: <sip:200f@(my IP):5060>
Call-ID: (redacted)
CSeq: 65436 OPTIONS
Max-Forwards: 70
User-Agent: FPBX-16.0.40.4(18.16.0)
Content-Length:  0

That’s an OPTIONS request, not a REGISTER request, but if you have confirmed that there is also no response to OPTIONS, it’s just as good. If there was a response, please post it, as well as a REGISTER.

Confirm that (my IP) means your public IPv4 address, same as you see at whatismyip.com .

Next, I suspect either a SIP ALG problem (make sure that you disabled anything related to SIP in your firewall router), or the source port number is being rewritten and sipdesk is ignoring the rport request.

Next, describe your networking setup. Router/firewall make/model? Any VoIP-related settings? Does it have your public IPv4 address on its WAN interface? If not, please explain (connected to ISP-supplied gateway, ISP does CGNAT, etc.)

Apologies for the late response and the incorrect log, however, I’ve made some progress.

I decided to try digging out an RPi and trying RasPBX on it, with this using the same settings you listed I was able to get it to register.

My main FreePBX instance is on a VM, so I think tomorrow I’ll try backing up the VM and trying a clean install to see if that works.

Make sure that you use bridged networking (PBX IP address is in same subnet as host). If you still have trouble, post details about virtualization setup.

Ok, so I’ve been messing around.

So far, the closest I’ve got with the main distro is using Asterisk 19 with a clean install and starting from scratch, but even this is very hit or miss and when it is working I can make outgoing calls but incoming give me an error on “invite” saying “failed to authenticate”.

Next thing to try might be DMZing the VM, at least temporarily, to make sure it’s not a firewall issue.

I’m also contemplating trying a Rube Goldberg option, using an old ATA with an FXO port as a bridge for another Grandstream ATA (the former has a broken FXS port).

My setup is a proxmox host with a quad Intel NIC PCI-E card. For the VMs each NIC uses PCI-E passthrough. One VM is my firewall pfSense which has 2 ports, one for WAN and LAN. Another port is used for Managing Proxmox and finally one is dedicated to FreePBX.

I have a static IP from my ISP.