Can't register extensions on softphones! 408 error

well I am totally new to this topic (this VOIP thing) , this is my first try and gosh ! it is an awful experience till now !
my host machine is running Arch linux and I installed centos 7 on virtualbox on my machine and also asterisk & freePBX installed as well. I’ve been trying for weeks now and finally I did able to install and run freepbx and asterisk.
I made a few extensions as sample and tried to make a call between them to test it but that did not work for me . I have zoiper on localhost ( centos guest OS ) and I can register extensions on it without any problem,
but when I try to register extensions on my smartphone or tablet or even my host Machine I get 408 error code. I did searched the web and found too many topics about this problem but none of them worked for me!
I tried :
1.connecting using 3 different ISPs ( to see whether my ISP blocks VOIP)
2.using different softphones on tablet and smart phone
3. I changed UDP port to somethng else
4. using TCP instead of UDP which caused another failing situation ( I think 502 error code )
and so much other stuff I can’t remember now

something strange is I can access admin page using my ip address on my smartphone and tablet.
I also checked asterisk logs and well there is nothing about failing extension registrations ! so I guess ,requests can’t even reach the asterisk on my guest machine ! my best guess is something preventing my machine from getting incoming request from outside world it might be firewall but I don’t know what should I do or this is the reason …

any Ideas ?!

thanks :slight_smile:

408 is a timeout

check asterisk sip settings for the channel driver of the endpoint you are trying to connect and insure you are using that port - if its something other than 5060 you need to specificy that in your server address

outside of the above you will need to look at a sip debug

if you see no activity when trying to connect you simply arent reaching the system on the correct address/port, are blocked by some mechanism, or dont have asterisk configured properly and listening on the correct interface/IP

thanks for your help ,
I solved the probelm after too much struggling …

well turns out that the firewall-cmd (centos7) did not let incoming requests reach the asterisk.
so the fix is simple :
firewall-cmd --zone=public --add-port=5060/udp --permanent
firewall-cmd --zone=public --add-port=5060/tcp --permanent

I managed to make a call but there was no data (voice) transfering.
so this is where you should read wiki about rtp.conf and config it :slight_smile:

anyway my problem is solved :slight_smile:

awesome !

obviously not a distro install ?