Cant register cp 88xx's in SCCP

Hi all, I have the following phones (all cisco’s), and thanks to instructions provided on this same forum, I was able to register only the spa525g’s with the sccp module,

( I am using the Asterisk 20.5.2 from the distro SNG7-PBX16-64bit-2306.iso )

  • cp 8841 - main phones
  • cp 8845 - camera phone
  • cp 8831 - conference phones
  • spa525g - secondary phones

I still can’t register the first three phones of that list, I downloaded the firmwares and put them on /tftpboot/firmware

I noticed that there is no SEPxxxxxxxxxxxx.cnf.xml file anywhere on the /tftp directory, however the phone is registered successfully and it can make/receive calls (I only had to change the operation mode on the phone from sip to sccp and reboot the phone, it initially took long time to boot looking for different xml files but and the end it go the configuration.

Also, the spa525g is registered, even if is still red on the SCCP Model Information table and surprisingly I cant find its xml file anywhere in the /tftpboot directory, how is it being registered even if is still red on the SCCP Model Informatin table?

[root@freepbx ~]# updatedb
[root@freepbx ~]# locate SEPB0FAEB2EFB82
[root@freepbx ~]# find /tftpboot -name SEPB0FAEB2EFB82.cnf.xml
[root@freepbx ~]#

Also, for the 8841, I did copied the firmware files from firmware directory to the /tftpboot folder based on a suggestion but is still not being registered, I did already a factory reset (reset all settings) on the 8841 and still stuck on these screens, what am I missing?


thanks a bunch!!

I’ve tried the same procedure about a monty ago. I quit trying the SCCP module as the project seems no longer maintained.
In it’s current state doesn’t produce working SEPmac files.

Be aware the 88xx phones are no SCCP phones but a form of Ciscoïfied SIP. I assume you have the enterprise firmware. My best advice is to purchase the SIP license (about €/$ 50,- per phone) to get them into 3PPC firmware. Fully working on FreePBX and a nice webinterface lije the SPA5xx series.

If you go my route please use the search on the forum. I went the USECALLMANAGER patch way. It’s a very timeconsuming hole. My server went live last Monday and the 8841 testphone had 90 calls, all funtions active. Recoverd by itself from a modem swap. All well.

Again it has to be asked, is it worth the pain to make these very cheap on ebay phones ‘kinda sorta work’ ?

I have the cmterm-88xx MPP firmware that I downloaded, do you know of a procedure or a link to a procedure so I can change the firmware ?

Thanks!

what would be cisco the models that work with asterisk sccp?

No it makes no sense to ask again. Doesnt really add to the discussion.

I have the MPP/3PPC firmware as well. But you cannot install it without a valid phone specific license file. Only to obtained from a official Cisco seller.

If you do manage to run the update, the phone will be stuck at bootscreen with a message like “Missing license file”.

The phones what SCCP-Manager is for are by now unsuppprted and very old. You can see the model numbers in the templates from SCCP manager.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.