Can't register any phones

Good afternoon all. In wanting to explore some of the features in *13, I loaded the latest beta (Asterisk 13/FPBX 12.0.3). I built out all my extensions that are on my current system (yes, I duplicated station passwords), and I’m unable to register phones. I’ve built them as PJSIP stations instead of the older CHAN_SIP, but switching this didn’t help at all.

Upon registration attempt, the phones cause the following entry to appear in the log:
(I tried to paste the text in, but the form kept masking half of the data in the preview - screenshot attached instead).
Note the “No matching endpoint” entry. Confirmed passwords were fine - changing ip to old system allows it to register with existing stored password).

Any thoughts on why it won’t let anything register? Phone is a Grandstream 3275, but I’ve got others (3240 and 2160/40/30) if need be.


You built them as pjsip and didn’t look at Port assignments. So you probably missed the whole thing about what port your phones should be connecting to. Now that they are sip you are reversed again and are trying to have your phones register to just pjsip but don’t have any pjsip accounts setup

I’m not convinced that’s true. PJSIP was on 5060, which is where my phones always registered on the old system. So, they’re still targeting the same port on both the old and new systems. When I tested by changing one to CHAN-SIP, I changed the phone’s target port to 5061, which is what was configured for that driver. Am I missing something?

The error log above says you are attempting to register against the pjsip driver. Without seeing your settings I just making an assumption though

I had done quite a bit of testing - at that point I believe it was a PJSIP extension and trying to hit 5060.

However, my sequence may have gotten out of whack. I did just force the phone to re-attempt registration, and if I change it to CHAN_SIP (and put on 5061), it registers. So it seems to only be a registration issue with PJSIP when its back on 5060.

Current setup - the extension has been set back up as a PJSIP station, and is pointing to 5060 again.

Did you restart Asterisk after making the port changes?

I haven’t made any port changes - only station changes. PJSIP was already configured on 5060, and CHAN_SIP was already on 5061. The port changes I spoke of were on the phone.

So, when I set the test extension as a CHAN device, I then went into the phone and told it to look at 5061 (it registered). I then change the phone back to PJSIP (save, and apply of course), then go back into the phone and tell it to hit 5060 this time.

Whenever its trying to register as PJSIP, it shows that "no matching endpoint found).

So, no other thoughts on this?

I have a similar problem after upgrade to FreePBX 12. After changing the SIP stack from pjsip to CHAN_SIP or reverse you have indeed to restart asterisk to become effective.

So I have set the advanced settings “SIP Channel Driver” to BOTH and restarted asterisk. And I changed one of my SIP extensions to use the pjsip driver and they fail to register (483 forbidden)

But where the hell do you specify the port numbers for both stacks ? CHAN_SIP seems to use the default 5060 port and my SNOM phones use 5060 as server port, so they keep trying to register to CHAN_SIP driver and not the PJSIP driver. So they fail with wrong SIP password - which is misleading because the peer does even not exist anymore as it is now present under pjsip endpoints.

even when changing the settings to only use pjsip and restart asterisk, my phones can’t register.

just noticed some errors during asterisk restart:

[2014-11-20 22:59:09] WARNING[2926]: res_phoneprov.c:1519 ast_phoneprov_provider_register: Provider ‘res_pjsip_phoneprov_provider’ cannot be registered: res_phoneprov not loaded.
[2014-11-20 22:59:09] ERROR[2926]: res_pjsip_phoneprov_provider.c:395 load_module: Unable to register pjsip phoneprov provider.

could this be the reason ?

But I still wonder where to set the CHAN_SIP and PJSIP port numbers in case both drivers are used !

SIP Settings. Look to the RIGHT for the “rnav”. It will have the options “Chan SIP” and “Chan PJSIP” in it. That is where you change port numbers

Hopefully this commit I just pushed forward will help others to find the new rnav.

thanks a lot for helping me out ! Honestly I wonder why this settings is so “hidden” ? I’ve been searching for hours … I guess it would have been much easier if this was directly under Asterisk SIP settings (or Advanced settings) in stead of an almost invisible box on the top right of the screen :frowning: .

It’s just like all the other rnavs in every single other module in freepbx.

indeed - but these ar used for creating instances of extensions, IVR, … not for basic settings, so that’s why I didn’t expect it there.

I have much the same problem, only I’m using port 5160 for PJSIP. No registration, and I just checked those tabs. 5060 for Chan_SIP and 5160 for PJSIP. Obviously, I’ve missed something.