Can't provision phones on FreePBX

I have recently switched to FreePBX from 3CX and I need help provisioning my IP Phones.

I currently have a Polycom VVX 400 phone and a Yealink T31P phone. I have tried to provision the phones to my FreePBX server which is in the cloud, however, every attempt of provisioning the phones fails and I cannot register it to the SIP Server. I don’t have the smart firewall enabled and I am wondering if it is something that I am doing wrong on my end.

Here’s the configuration of my Polycom VVX Phone Lines below.

This experience overall is very frustrating so if you have any suggestions on how to fix it, please tell me. Thank you!

A couple of quick things to check. On the GUI it shows that Authentication is Disabled. Second thing is to check you are using the correct SIP port. Check in FreePBX as it maybe a different port particularly if you are using PJSIP.

1 Like

So I’ve done what you did, however it still wont register with the system. I am using the sip port chan_pjsip and changed the port on the phone to 5160 instead of 5060. However I found out that port 5060 was indeed the correct port for it to work. I also tried changing the port type from DNSNAPTR to UDPONLY, yet nothing happens.

Heres my config on the FREEPBX Server:

You also appear to have SRTP enabled, if you don’t have that enabled in FreePBX that could cause a problem. If that still doesn’t work you may need to check the Syslog of the phone or do a PCAP.

Goto advance and set nat = never if you are using chan sip,
If using chan pjsip check for ports should 5060,
If you are using 5160 then try to authenticate like YOURIPADDRESS:PORT eg
Try a short password while registering the phone.
Hope this will sort out your issue.

I have tried both and still, the phones do not provision. I tried running an open port checker and it reports that the port 5060 and 5160 are closed. I also would like to note I am running this server remotely on DigitalOcean.

I would verify that your server is not running any other firewall that might be blocking ports. I am not sure what the “Server Auto Discovery” is on that phone, so I’d test with turning that off and see if it makes a difference.

Triple-check that the FreePBX Firewall is not on. Specifically check for bans at the bottom of the Intrusion Detection tab, and check that the interface is properly assigned on the Interfaces tab.

Lastly, view the server log to see if anything is happening while you are attempting to register. You can view logs from within FreePBX or from the command line with: tail -f /var/log/asterisk/full

I should add - you do want a firewall. My suggestion of checking that it is not on is for troubleshooting only.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.