Can't make Yealink T23G work!


#1

Using FreePBX 15.0.17.34

And EndPoint Manager 15.0.39.59

I’m trying to configure a Yealink T23G

I’m trying to follow the wiki here:
https://wiki.freepbx.org/display/FPG/Supported+Devices-Yealink#SupportedDevices-Yealink-YealinkT20P,T21P,T22P,T26P,T28P,T32G,T38G,VP-2009&VP-530

When I get here:

I input the FreePBX address.
I tried both FQDN and IP address.

After I press confirm, nothing happens.
I’ve also tried to reboot, nothing happen.

I made a factory reset, added the auto-provisioning address, rebooted, still nothing.

What am I doing wrong?


#2

Sorry that I don’t know the details, but I believe that Server URL has to be a URL, for example
tftp://10.10.10.1/somefolder/101112131415.cfg

Find out where the provisioning file is stored and what protocol is being used and set it up accordingly. Do you have another (already provisioned) device on the system that you can look at?


(Jared Busch) #3

He said EPM so it should be in /tftpboot like normal

With an internal IP being shown tftp should already just work by IP. with no protocol specified the phone tries that and http IIRC.

For http on a default system with EPM, the structure matching his screenshot is http://10.10.0.1:84

No folders. Been so long since I had tftp I have no idea why that syntax is anymore.


#4

EndPoint seems to be using the following ports:

In my Yealink image, I made the following config (and chose HTTP for provisioning)

I’ll try the IP with the port number, but I would also like to know:

How does the phone apply the auto-provisioning setting?

Do I need to reboot?

I just click Confirm and nothing happens.


(Jared Busch) #5

After you click confirm to save the settings, you click the autoprovision now button.


#6

Oh god…

I can’t believe it but that was it.

I did NOT click the “Auto Provision Now” button.

I just didn’t notice it.

I’m ashamed and defeated.

But I’m leaving this message for posterity.

Don’t be like me.
Click the button before rebooting 999999 times and troubleshooting for 40 hours.


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.