Can't make internal calls

Hello,

i installed the asterisk and freepbx, version Asterisk 16.13.0.
I have already create two extensions (pjsip) from freePBX (not CLI),
now i am trying to call from one to another but always i get the error

WARNING[7272][C-00000009]: pbx.c:2927 pbx_extension_helper: No application 'Macro' for extension (ext-local, 120, 3)

WARNING[7272][C-00000009]: pbx.c:2927 pbx_extension_helper: No application 'Macro' for extension (ext-local, h, 1)

Some logs:
Contact: 119/sip:[email protected]:62619;rinstance=ee b29f55906c Avail 141.192
Contact: 120/sip:[email protected]:62619;rinstance=5a 53af9961c8 Avail 134.868

Did you manually install everything? If so, you did not build Asterisk to include the app_macro module (which has to be explicitly selected in make menuselect) which is needed for FreePBX.

1 Like

I followed this guide

How can i check if i have installed it ?

Since you don’t have the “Macro” dialplan application then you don’t. It would need to be selected by using “make menuselect” when building Asterisk and selecting app_macro under “Applications”.

Can i fix it now or i need to re install it ?

You need to enter the Asterisk source code directory, enter menuselect as I mentioned, select app_macro, and build. It should only build app_macro after which you can use “make install” to install it.

I have no idea if there’s other things you may be missing though that could cause problems.

ok, i just entered to the menuselect, why is shown as Deprecated ? Is this normal ?

The module is deprecated, thus why you have to explicitly enable it. FreePBX still uses its functionality so you have to enable it.

i just do it and now works perfect.
But when it will be removed from Asterisk how we will make it work without app_macro ?

That has not been decided, and if it were to be removed then it would be up to FreePBX to make it work.

Thanks for your information and the solution for my problem.
Have a nice day!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.