FreePBX | Register | Issues | Wiki | Portal | Support

Can't install/upgrade any modules FreePBX 12 "GPG Verify File check failed"


(Semen Bobkov) #1

Hi. I installed FreePBX-6.12.65-30 distro with Freepbx 12.0.45. When i try to install/upgrade any modules through Module Admin i get an error “GPG Verify File check failed”. When i try to verify modules through OS cli like “gpg --verify framework-12.0.76.6.tgz.gpg” i get en error “Can’t check signature: No public key”.In the same time i have few servers with the same distro installed, where the same modules files installing without any problems. GPG verifying on these servers gives out the same error “Can’t check signature: No public key”, but when installing modules through Module Admin/amportal i get no errors. Looks like on these servers GPG verification is not needed for modules install/upgrade. I have the same problem when installing freepbx 12 manually on centos 6. Module Signature Checking is disabled, time and date is ok on server. Is there any way to disable GPG verifying for modules install/upgrade?


(Itzik) #2

Try

amportal a ma refresthsignatures

(Semen Bobkov) #3

I tried

Get no error in output. But nothing changed when i try to install/upgrade modules.