Can't get System Admin upgraded to

Our original install was from a 2.8 distro. We hadn’t done any patching until last night. Patched all 2.8 modules up to 2.9 as possible, then installed the 2.10 upgrade module, then upgraded.

All the modules upgraded and we were able to install subsequent updates, except System Administration, which is stuck at When we try to update it to we get these two errors:

System Admin cannot be upgraded:
PHP version 5.3.0 or higher is required, you have 5.2.17
PHP Component Zend Guard Loader is required but missing from you PHP installation.
Please try again after the dependencies have been installed.

I tried using YUM to update PHP, but it doesn’t seem to be finding any updates at the (default) mirrors of fastmirror and KMOD:

yum check-update php


loaded plugins: fastmirror, kmod
loading mirror speeds from cached hosts file

yum update php


loading plugins: fastestmirror, kmod
loading mirror speeds from cached hosts file
Setting up Update Process
No Packages marked for update

I saw some posts from January describing similar issues, but nothing with a fix that works for us.

Any help appreciated.

A little confused… I thought the first FreePBX Distro included 2.9 BETA.

Try running the following at a command prompt:
cat /etc/asterisk/freepbxdistro-version

If the command returns a version you will need to run the upgrade scripts sequentially as posted here:

If it doesn’t return a version, you will need to determine the source of the installation.

So does this mean I start with the script, here:


And then run the next two in sequence?

Thanks for the assist!

did u find what should we do ?


I never got a response to my post with the requested information and additional query, so I’ve not taken any action.

Yes you would start with the next script in the order based on what version you have.

I ran all four upgrade scripts, with a reboot between each.

The FreePBX GUI is running and now reports all modules up to date.

I did notice one error at system boot:

Starting wanrouter:
ERROR: Wanpipe configuration not found:

Phones are working and we have a green board on the System Status page.

The only other issue, which I think is unrelated, is that the phones are an hour behind since the DST change, even though CentOS is correct.